It's possible to have hamburger menu in a different locale than the currently selected one

RESOLVED INCOMPLETE
(NeedInfo from)

Status

()

P2
normal
RESOLVED INCOMPLETE
a year ago
a year ago

People

(Reporter: Grisha, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

unspecified
Points:
---

Firefox Tracking Flags

(fennec+, firefox57-)

Details

(Reporter)

Description

a year ago
I'm not sure how I got into this state, and I can't seem to get a set of STRs - although I'll keep trying - but what I'm observing is the following:

- my current locale is set as system default, so en-CA
- at some point prior, I've had my locale set to 'ru'
- my settings menu is in en-CA, in English
- my main menu under the hamburger icon is in Russian
- going back and forth from the settings doesn't change the situation
- switching locale to something else seems to have "fixed it"
(Reporter)

Updated

a year ago
tracking-fennec: --- → ?
Hi Wesly & Joe. Please help prioritize
Hi Jing Wei. Is this something you are working on?
Flags: needinfo?(wehuang)
Flags: needinfo?(topwu.tw)
Flags: needinfo?(jcheng)
tracking-fennec: ? → +
Probably related to Bug 1378501 and Bug 1389709 and Bug 1390822.
P1 though we may not be able to really get it in this release (Nightly 57).
Flags: needinfo?(wehuang)
(Reporter)

Comment 4

a year ago
Wesly, Joe, is it possible to get additional resources to tackle these various bugs? Each individual bug might not _feel_ very serious, but it all adds up to a rather unpolished experience. We have a lot of bugs around the edges of our regular UI flows.

Given the importance of 57, the optics here don't look very good.
tracking-firefox57: --- → ?
Flags: needinfo?(wehuang)
:Grisha, :rnewman is about to land a patch in bug 1378501 which may fix some of the observed behavior. I also just landed 1397925 which may fix other things.

We now have a meta bug for locale related issues - bug 1398209 - and once :rnewman's patch lands I'll reevaluate all bugs on that list, including this one.

Your STR doesn't mention if you kept Fennec locale as "System Locale" or did your `at some point prior, I've had my locale set to 'ru'` means that you set it manually to `ru`.
If you changed it manually to `ru` then it is expected that your Fennec locale is ru. If you follow OS locale and your OS locale is en-US, and yet your Fennec locale is in `ru`, that's a bug.
(Reporter)

Comment 6

a year ago
Excellent, thanks Zibi.

Perhaps the STRs aren't entirely clear. I've changed Fennec's locale from System Locale to 'ru'. Then I've changed it back to System Locale (en-CA). What I observed, intermittently, is that the locale of the main menu would remain as 'ru', but the rest of Fennec would be on the correct locale (en-CA).

I've seen this happen since with other locale combinations as well.
Does this also affect release and beta?
Flags: needinfo?(gkruglov)
I *mostly* cannot reproduce it in today's nightly.

I used the following STR:

1) Select OS locale in Fennec (en-US for me)
2) Open the main menu. It should be in en-US
3) Go to Settings and switch locale to pl
4) Go back to main menu. It should be in pl
5) Go to the Settings and switch the locale back to OS locale (en-US)
6) Go back to the main menu. It should be in en-US

It worked for all items in the main menu except of the "Report issues with the website" which is one-but-last item and it remained in "pl". All other items are in en-US.
We will start to produce beta version of 57 for Fennec next week.
Zibi, are you working on it?
tracking-firefox57: ? → -
Flags: needinfo?(gandalf)
Nope. I believe it to be almost completely fixed.

There's one item remaining that must be going through different codepath which causes it to not get updated on locale change.

We need someone who understands the Java code from Fennec (which is how we build the hamburger menu) to debug.
Flags: needinfo?(gandalf)

Updated

a year ago
Flags: needinfo?(wehuang)
Priority: -- → P2
(Reporter)

Comment 11

a year ago
FWIW I haven't seen this happen recently (but neither did I try hard to repro).
Flags: needinfo?(gkruglov)
[triage] No specific STR and there are other issues are open that this bug describes that have STRs (e.g. bug 1399573) and a meta bug 1398209 so I think we can close this one.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.