Popovers are rendered incorrectly on Linux

RESOLVED DUPLICATE of bug 1377321

Status

()

Core
Graphics: WebRender
P3
normal
RESOLVED DUPLICATE of bug 1377321
10 months ago
5 months ago

People

(Reporter: Jonas Platte, Unassigned)

Tracking

(Blocks: 2 bugs)

57 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 unaffected, firefox57 unaffected)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

10 months ago
Created attachment 8898032 [details]
scrot.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36
Build ID: 20170816100153

Steps to reproduce:

Click one of the buttons in the Firefox UI that makes a popover appear:

 * The view selection in the sidebar
 * The leftmost part of the url bar, left of the actual URL (see attached screenshot)
 * The three dots at the right side of the url bar


Actual results:

The popover was shown, but with a dark-red (#4b0000) background around it.


Expected results:

The popover should have been shown with no background.
(Reporter)

Comment 1

10 months ago
Also:

* My Nightly version is 57.0a1 (2017-08-16) (64-bit)
* This problem happens with gfx.webrender.enabled
  * Does not matter whether gfx.webrendest.enabled or gfx.webrender.layers-free are true or false
* I reproduced this bug both on i3 (X.org) and gnome-shell (Wayland)
Making this not blocking release as it's Linux-only and the initial release will be Windows-only.
Blocks: 1386674
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Whiteboard: [gfx-noted]

Comment 3

10 months ago
If I open a popup with webrender enabled, the following terminal message is outputted:

ERROR:webrender::frame: ERROR: Invalid window dimensions! Please call api.set_window_size()
Priority: -- → P3
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
(Reporter)

Comment 4

8 months ago
I have switched to the Developer Edition as my main browser since filing this bug and I can't reproduce it there. However, I can still reproduce it with Firefox Nightly 58.0a1.20171104, with the small difference that the area aroud the popover is now white instead of red.
Click on the burger button to check if it has a white (in the past: red) border.

mozregression --find-fix --bad 2018-01-14 --good 2018-01-17 --pref gfx.webrender.all:true
> a99a53c8f13d	Nicolas Silva — Bug 1377321 - Only use WebRender for top-level windows and remote content. r=kats

It unethically switched some work back to C++ code, but I can understand that intermediate step. ;-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1377321
You need to log in before you can comment on or make changes to this bug.