Display images while loading not suited for page backgrounds

RESOLVED DUPLICATE of bug 85771

Status

()

Core
ImageLib
--
minor
RESOLVED DUPLICATE of bug 85771
16 years ago
16 years ago

People

(Reporter: Andrei Boros, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

All images are displayed "while loading" and this also applies to page
background images.
Actually displaying a backgroundimage while loading can be quite annoying,
especially if it has areas with high contrast between page bgcolor and the
contents of the background.


Reproducible: Always
Steps to Reproduce:
1.have page defining <body background="somefile">
2.load this page on a slow link and somefile is somewhat large.
3.

Expected Results:  Except to see the behaviour of Netscape 3&4 where backgound
images are displayed after complete load.
Netscape 3 has an option to display while loading or after. With "while loading"
set, backgounds are always displayed "after".

Having pages with a tiled graphic effect on the background, or the background is
an interlaced GIF, the hole page changing quite radically and quite often while
loading such a background over a slower link is definitely something annoying or
confusing.

Comment 1

16 years ago
reassigning
Assignee: morse → pavlov
Component: Image Management → ImageLib
QA Contact: tever → tpreston

Comment 2

16 years ago
backgrounds are no longer displayed until they are completely loaded
see bug 85771

You need 1.0rc1 or a nightly to see this.

*** This bug has been marked as a duplicate of 85771 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.