If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong character encoding for media devices in about:support

RESOLVED DUPLICATE of bug 1384944

Status

()

Core
Audio/Video
RESOLVED DUPLICATE of bug 1384944
a month ago
a month ago

People

(Reporter: Torbjörn Andersson, Assigned: chunmin)

Tracking

56 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170815141045

Steps to reproduce:

Using the 64-bit version of Firefox Beta for Windows, I entered "about:support" into the address bar.


Actual results:

Under the Media heading it lists output and input devices. Presumably it gets these from Windows, and the names are localized (in my case they're in Swedish). However, it looks like they're encoded as UTF-8 while Firefox assumes they're not.

For instance, in one of the entries I see "Hörlurar på headset (Microsoft LifeChat LX-3000)"


Expected results:

It should have been "Hörlurar på headset (Microsoft LifeChat LX-3000)"

Updated

a month ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
Chun-Min, you might want to have a look at this one as well.
Assignee: nobody → cchang
Status: UNCONFIRMED → NEW
Rank: 19
Ever confirmed: true
See Also: → bug 1384944
Torbjörn, can you try to reproduce using a Firefox Nightly build [0] ? Chun-Min has recently fixed a very similar problem (however it was first reported with a Japanese Firefox), but I think it has not made it in time for 56. We can probably uplift it so that the general population does not see this bug.

[0]: http://nightly.mozilla.org/
Flags: needinfo?(eriknospam)
(Reporter)

Comment 3

a month ago
You're right, it works as expected in Nightly. (Version 57.0a1, Build ID 20170817100132)

I guess I should have tried that right away, but I was nervous about not being able to downgrade to Beta again and I do want to hang on to that Tab Groups add-on for just a little longer. But I think I have a backup of my profile now, so it should be ok. :-)
Flags: needinfo?(eriknospam)
Thanks, duping accordingly.
Status: NEW → RESOLVED
Last Resolved: a month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384944
See Also: bug 1384944
You need to log in before you can comment on or make changes to this bug.