Crash in mozilla::ipc::ProcessLink::SendMessage | IPC_Message_Name=PExternalHelperApp::Msg_OnDataAvailable

RESOLVED DUPLICATE of bug 1274706

Status

()

P3
critical
RESOLVED DUPLICATE of bug 1274706
a year ago
9 months ago

People

(Reporter: gcp, Unassigned)

Tracking

({crash})

Trunk
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-f54a2d13-a5bb-4701-a164-ab5790170817.
=============================================================

Currently Nightly, Linux x64

STR:

1) Open https://ia902603.us.archive.org/30/items/byte-magazine-1979-08/1979_08_BYTE_04-08_LISP.pdf
2) Try to save the PDF

I filing this in Networking:HTTP based on some blaming on the closest code.
This crash is complaining about trying to send an IPC message over 256 MB.
From the crash report it is trying to send a 265 MB PExternalHelperApp::OnDataAvailable message, which is about the size of the pdf file provided in the STR.

There was a similar issue in PWyciwygChannel IPC (see bug 1335989) and the solution is to split it into smaller chunks of IPC messages.

Updated

a year ago
Component: Networking: HTTP → IPC
Priority: -- → P3
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1274706
Crash Signature: [@ mozilla::ipc::ProcessLink::SendMessage | IPC_Message_Name=PExternalHelperApp::Msg_OnDataAvailable]
You need to log in before you can comment on or make changes to this bug.