browser.download settings seem to be completely ignored

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: turbobeholder, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

Reporter

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170814194055

Steps to reproduce:

Attempt to save a page or file, whether via hotkey, main menu or "save as" context menu.

This happens after upgrade to package v. 55.0.1+build2-0ubuntu0.16.04.2 (amd64).


Actual results:

The location offered for saving is always last directory used for the host.
Automatic Save Folder add-on does nothing (disabling it changes nothing, too).


Expected results:

Normally values of browser.download.folderList, browser.download.useDownloadDir, browser.download.importedFromSqlite, etc would affect this;
Automatic Save Folder add-on is supposed to override these settings.
Component: Untriaged → Downloads API
Product: Firefox → Toolkit

Comment 1

2 years ago
Automatic Save Folder is a legacy add-on, and like other similar ones it will not be supported in future versions of Firefox, but it may have stopped working earlier due to compatibility changes.

If I understand the description correctly, this is not a bug in Firefox but with the add-on, so it should be reported to the add-on author. If I misunderstood, feel free to reopen the bug and clarify.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.