Menu item not displayed correctly in the main menu drop-down list if Firefox browser is closed forcefully

RESOLVED DUPLICATE of bug 1392322

Status

WebExtensions
Android
RESOLVED DUPLICATE of bug 1392322
10 months ago
10 hours ago

People

(Reporter: CosminB, Unassigned)

Tracking

Trunk
All
Android

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

Attachments

(2 attachments)

9.82 MB, application/x-zip-compressed
Details
7.76 MB, application/x-zip-compressed
Details
(Reporter)

Description

10 months ago
[Notes]:
This issue is a follow up from https://bugzilla.mozilla.org/show_bug.cgi?id=1386786#c14

[Affected versions]:
- Firefox 57.0a1 (2017-08-16) 
- Firefox 56.0b3
- Firefox 55.0.2
 
[Affected platforms]:
- Android 6.0.1

[Prerequisites]
- set xpinstall.signatures.dev-root to true
- set extensions.webapi.testing to true

[Steps to reproduce]:
1.Install https://addons-dev.allizom.org/en-US/android/addon/test-android/ 
2.Open multiple tabs (at least two) 
3.Open the second tab and observe the item displayed in the drop-down list (Bar).
4.Close Firefox forcefully with the second tab opened.
5.Open the browser again and observe the item displayed in the drop-down list (Foo).


[Expected results]:
- The item displayed in the drop-down list is Bar.

[Actual results]:
- The item displayed in the drop-down list is Foo.

[Additional notes]:
- Refreshing the web page does not change the item’s name in the drop-down list.
- The name is changed only if you navigate to another tab and come back.
- Intermittently issue for 56.0b3 the actual result is a bit different, the main title “Truuske” is displayed for all the tabs after you reopen the browser.
- This issue reproduces constantly.
- Please see the attached video for this issue.
(Reporter)

Comment 1

10 months ago
Created attachment 8898244 [details]
56.0b3Truuske.gif.zip
(Reporter)

Comment 2

10 months ago
Created attachment 8898246 [details]
NightlyFoo.zip

Comment 3

10 months ago
Hi Cosmin,
I suspect that this one could be related to Bug 1392322, can you verify if this issue is still reproducible in a Nightly where Bug 1392322 has been already landed?

if it is not reproducible anymore, we can close this as a duplicate of Bug 1392322.
Flags: needinfo?(cosmin.badescu)
(Reporter)

Comment 4

10 months ago
Thanks Luca!

I can confirm that this bug is a duplicate of Bug 1392322, this issue is not reproducing anymore.

Tested on Fennec 57.0a1 (2017-08-23) under Android 6.0.1.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Flags: needinfo?(cosmin.badescu)
Resolution: --- → DUPLICATE
Duplicate of bug: 1392322

Updated

10 hours ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.