File Bookmark... redraws infinitely

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: Nick Kocharhook, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When there are only three folders to choose from, the File Bookmark window/sheet
draws the outliner, but then continuously redraws it (ignoring the other
widgets). The only way to stop it is to resize the window/sheet.

It looks like it can't decide what to do with the third folder, which won't fit
in the outliner. Increasing the number of folders makes the problem go away.

The symptoms seem somewhat similar to bug 122055, but I'm not sure if they're
related.

Mac OS X build 041712 (rc1).

Comment 1

16 years ago
sounds like bug 121583 ..

is the scrollbar appearing/disappearing?

Comment 2

16 years ago
Nick, can you provide specific steps to reproduce this problem so someone can
try to confirm it easily?
(Reporter)

Comment 3

16 years ago
Yes, the scrollbar is reappearing and disappearing, however I wasn't able to get
this to occur with more than three folders in the list.

Steps to reproduce:

1. Create a new profile.
2. Switch the theme to Modern.
3. Try to "File..." a bookmark.
4. You may need to fiddle with the window a bit so the outliner is right on the
boundary.
5. Your window will resize continually.

Comment 4

16 years ago
Can't seem to make it happen using RC1.
(Reporter)

Comment 5

16 years ago
Well, I just followed the steps I posted in comment 3 in two different builds
(041712 [rc1] and 042808 [latest trunk]) and was able to reproduce the problem.
In fact, I didn't even need to resize the window, it just never fully drew
*until* I resized it. (There's no way to close the window without the Cancel
button, which hadn't been drawn yet.)

I want to change what I said earlier about the scroll bar disappearing and
reappearing. When using the Modern theme, this doesn't happen. In fact, none of
the window gets drawn, outside the outliner. I'll attach a screenshot.

Sometimes when the prefs are set to Modern, the classic File Bookmark... window
comes up anyway. And in those cases, you can get the outliner to resize (not as
quickly, and after drawing the other elements in the window). When that happens,
the scroll bars to go away and come back repeatedly.

However, I think this is probably a different bug. When you're using Modern,
it's MUCH faster. So fast, that you can hardly see any change. The pseudo-modern
window redraws very slowly, and after the rest of the window has been drawn.
(Reporter)

Comment 6

16 years ago
Created attachment 81622 [details]
Screenshot of the badness

*sigh* OK, I'll get this straight eventually.

I can't get this to occur when the theme isn't set to Modern. However, I just
tried it again, and I *can* get the slow resizing to happen whether the File
Bookmark... window decides to use the Modern theme or not (because sometimes it
doesn't). I had previously said that I thought it was a different bug, but I've
changed my mind.

Am I still the only one that can reliably reproduce this?

Comment 7

16 years ago
Does it happen using a new Mozilla user profile?
(Reporter)

Comment 8

16 years ago
Yes, it does. I followed my instructions in comment 3 exactly.

I just tried this on the latest nightly (043010), and it's still there.

Greg, you seem to triage Mac bugs quite often, but I just want to make sure: are
we both running OS X? I just tried in OS 9 with 043010, and the bug did not appear.

Comment 9

16 years ago
Nick, yes, I'm running OS X 10.1.4.
(Reporter)

Comment 10

16 years ago
Well, I just tried this in rc2 (051005) and the latest nightly (0517whatever)
and it did not appear. So I'm resolving this WFM.

Will reopen if I see it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.