Context menu Save link waits for response before fork

VERIFIED DUPLICATE of bug 133732

Status

SeaMonkey
General
--
minor
VERIFIED DUPLICATE of bug 133732
16 years ago
13 years ago

People

(Reporter: Andrei Boros, Assigned: Matthew Paul Thomas)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

Selecting from context menu "Save link as" will not fork immediatly (like new
window or new tab), but instead will wait (apparently for http response from
server) before the "Save As" dialog appears.
On slow links from save link as and Save as dialog appearance there will be a
considerable time. Also, the interface does not show any indication that
something is happening (the request for that link).
Same applies for SHIFT-CLICK on a link.


Reproducible: Always
Steps to Reproduce:
1.SHIFT-CLICK on a link, or select Save link as from context menu (works best on
slow links)
2.
3.

Actual Results:  A considerable amount of time may pass between the requested
action and the dialog to appear.
repeating step 1 before any dialog appears seems to queue these requests (or
fork them, not yet sure), but for each time step 1 is performed, sometime later
a dialog will appear.

Expected Results:  Expect Save As dialog to appear instantly, using the filename
specified in the link as filename to save on disk.

See behaviour of Netscape 3&4 performing the same steps.


Open link in new window or new tab will immediatly fork a new window or tab,
send the request, wait for a reply, etc.

However, Save Link does not fork immediatly, and for the dialog to appear it
apparently waits for the request to be answered, probably to get the on-server
filename (?)
Whiteboard: DUPEME

Comment 1

16 years ago
fork is wrong. mozilla rarely forks.

your guess at the end is correct, we're getting the filename from the server.
Yes, we're waiting to get the "Content-Disposition" header, which includes the
filename the server wants the file saved as.

Duplicate of "Save as waiting for reply from server before showing dialog
(should time out)"

*** This bug has been marked as a duplicate of 133732 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
v
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.