If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

default_area is cached in browser_action and does not change

RESOLVED WONTFIX

Status

()

Toolkit
WebExtensions: Frontend
RESOLVED WONTFIX
a month ago
a month ago

People

(Reporter: erosman, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a month ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170805085114

Steps to reproduce:

Changes to "browser_action" - "default_area" has no effect after the first installation.

Once an addon is installed (temporary or otherwise), changing the "default_area" and reloading the addon, removing and reinstalling the addon, restarting the Firefox has no effect on the "default_area".

It seem the first value is cached and does not change or get updated with reload or reinstall.

Tried on FF55-56


Actual results:

 


Expected results:
It's not after the first installation, it's after the user moves a button explicitly.  This is working as intended, as we want to respect the user's wish where they meant for the extension to appear.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a month ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

a month ago
Clarification: The position of the button/icon was not changed by the user manually. The position was the default location set by the manifest.json
(Reporter)

Updated

a month ago
Flags: needinfo?(tomica)
Still, after the extension is updated, the user probably expects the button to be in the same place they have last seen it.

Anyway, this is how CustomizableUI works, it remembers the the last position of every button.
Flags: needinfo?(tomica)
You need to log in before you can comment on or make changes to this bug.