Uninstalling theme removes skin without restart

RESOLVED EXPIRED

Status

--
major
RESOLVED EXPIRED
17 years ago
9 years ago

People

(Reporter: bugzillawatcher, Unassigned)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    20020417

I had Pinball installed and when i uninstalled it removed the skin directly
causing the classic skin to be totally messed. (See screenshot)


Reproducible: Always
Steps to Reproduce:
1. Go to Themes in Preferences, choose Pinball and click "Uninstall theme"
2. When button is clicked Pinball is removed without no need of restart.
3. Classic skin looks messed up until you restart Mozilla.

Expected Results:  Mozilla should not remove the Pinball skin until restart.
(Reporter)

Comment 1

17 years ago
Created attachment 80366 [details]
Classic skin messed up

Comment 2

17 years ago
confirming on linux trunk 2002042200

After performing the above steps, the browser falls back to the classic theme
for the chrome that's not cached. (my guess)
In any case, it's visually disturbing :)

os -> all
OS: Windows 2000 → All

Comment 3

17 years ago
now to actually confirm :-/
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

17 years ago
One other misleading thing is that if you for example are using Pinball and
choose to unistall an other theme like eskimo I get this prompt that a restart
is required...
(Reporter)

Comment 5

17 years ago
All the issues that i mentioned are fixed with build 20020425. Changing to WFM.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
Seing this again with build 20020603 on Windows 2000 and build 20020607 on Mac
OS 9. Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Updated

17 years ago
Keywords: mozilla1.1
Hardware: PC → All

Updated

17 years ago
Keywords: regression

Updated

16 years ago
Keywords: mozilla1.2

Comment 7

16 years ago
Is this still broken?

Comment 8

16 years ago
Just uninstalled Hybrid and it went back to Classic with no problem.
Except that you get the "Changes will apply next time you restart" something,
which is wrong, the changes happend immediately.
(Reporter)

Updated

16 years ago
Keywords: mozilla1.1, mozilla1.2
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
Assignee: shliang → nobody
Status: REOPENED → NEW
QA Contact: pmac → themes

Comment 9

10 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago9 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.