Intermittent /service-workers/service-worker/registration-updateviacache.https.html | register-with-updateViaCache-all-then-none - assert_not_equals: Imported script should have updated got disallowed value 1503029624.95

RESOLVED FIXED in Firefox 57

Status

()

RESOLVED FIXED
a year ago
a year ago

People

(Reporter: intermittent-bug-filer, Assigned: bhsu)

Tracking

(Blocks: 1 bug, {intermittent-failure})

unspecified
mozilla57
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox57 fixed)

Details

(Whiteboard: [stockwell fixed:logic])

Attachments

(1 attachment)

HoPang, are these related to bug 1353636?
Flags: needinfo?(bhsu)
15 failures in 949 pushes (0.016 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 8
* mozilla-inbound: 5
* mozilla-central: 2

Platform breakdown:
* osx-10-10: 12
* macosx64-stylo: 3

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1391532&startday=2017-08-14&endday=2017-08-20&tree=all
(Assignee)

Comment 3

a year ago
I believe it has something to do with that :(

Let me investigate this. At this moment, I am very curious about the 15 failures last week. They all happened on osx, does that lead to anything helpful to solve this bug?
Assignee: nobody → bhsu
Flags: needinfo?(bhsu)
The mac-specific failures are probably just a timing issue.  Do you have rr setup locally at all?  Maybe this would reproduce under rr chaos mode.
(Assignee)

Comment 5

a year ago
Thanks, let me find a mac machine and setup an rr on it.
(Assignee)

Comment 6

a year ago
Oh, I just find out that we don't have rr for osx now, I am now falling back to my Linux...
Yea, I meant maybe rr chaos on Linux would trigger similar race condition we see on Mac.  Sorry for my confusing comment.
this has 55 failures since August 18th:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1391532&startday=2017-08-17&endday=2017-08-24&tree=all

I ran across this and was excited to see work was being done on this already!  Thanks for jumping on it.
Whiteboard: [stockwell needswork]
44 failures in 908 pushes (0.048 failures/push) were associated with this bug in the last 7 days.   

** This failure happened more than 30 times this week! Resolving this bug is a high priority. **

** Try to resolve this bug as soon as possible. If unresolved for 2 weeks, the affected test(s) may be disabled. ** 

Repository breakdown:
* autoland: 17
* mozilla-inbound: 10
* mozilla-central: 9
* try: 8

Platform breakdown:
* osx-10-10: 31
* macosx64-stylo: 11
* macosx64-nightly: 1
* macosx64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1391532&startday=2017-08-21&endday=2017-08-27&tree=all
Priority: P5 → --
Whiteboard: [stockwell needswork] → [stockwell needswork:owner]
(Assignee)

Comment 10

a year ago
Created attachment 8902632 [details] [diff] [review]
Preserve the precision of a timestamp when converting it to string

Hi Ben, and sorry again for not being able to reproduce this.

After thinking this case over, I humbly think the root cause is the precision
of the timestamp is too low  which is 10^-2 sec in the testcase. By applying
this patch, we can make the precision reach to 10^-6 sec. Since it does no harm
to anything, I suggest we land this patch and checko how it would help.
Attachment #8902632 - Flags: review?(bkelly)
Attachment #8902632 - Flags: review?(bkelly) → review+

Comment 12

a year ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/6c8a5a8f95aa
Preserve the precision of a timestamp when converting it to string. r=bkelly
Keywords: checkin-needed

Comment 13

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/6c8a5a8f95aa
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox57: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
27 failures in 939 pushes (0.029 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* autoland: 11
* try: 9
* mozilla-central: 4
* mozilla-inbound: 3

Platform breakdown:
* osx-10-10: 17
* macosx64-stylo: 8
* windows7-32: 1
* macosx64-devedition: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1391532&startday=2017-08-28&endday=2017-09-03&tree=all
Whiteboard: [stockwell needswork:owner] → [stockwell fixed:logic]
You need to log in before you can comment on or make changes to this bug.