lock left on file uploaded via form

VERIFIED DUPLICATE of bug 126829

Status

Core Graveyard
File Handling
VERIFIED DUPLICATE of bug 126829
16 years ago
2 years ago

People

(Reporter: alan, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
May belong under Form Submission component instead of or as well as File Handling.

Submitting a file to http://validator.w3.org/file-upload.html seems to leave a
lock on that file (either local or accessed across our home-office network). 

After submission of a html file to the validator, I get a "sharing violation"
alert when I attempt to re-save the file. If the submitted file is located on
another machine and being accessed over the network, it is also locked on the
machine where it actually lives. No such problem is evident when submitting
files to the validator with IE 5.5. The lock is cleared when I submit another
file or if I close the browser window from which I submitted the file to the
validator (with mozilla still running other windows) but does NOT clear if I
merely close the tab with the submit results (running in tabbed mode).

I think this bug has existed for quite a while now but this is the first time I
have managed to actually pin it down. I downloaded RC1 specifically to see if
the bug was still present (it is).

Comment 1

16 years ago
I run Win2K SP2 with Mozilla 1.0 RC1 (Build 2002041711) und uploaded a document
using phpMyExplorer. After uploading the file I couldn't change it, so the file
seems to be locked (Windows Explorer reports a sharing violation). After
terminating and restarting Mozilla, the lock vanished and the file could be
edited again.

Comment 2

16 years ago
This is a duplicate of bug 126829, which has been checked in on trunk only.


*** This bug has been marked as a duplicate of 126829 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.