Closed Bug 1391614 Opened 3 years ago Closed 3 years ago

Update webrender to 310af2613e7508b22cad11e734b8c47e66447cc7

Categories

(Core :: Graphics: WebRender, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 1 open bug)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1389497 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
WR @ 7f2fbdb69d968833bfdb82246d2ab67f0915045f

https://treeherder.mozilla.org/#/jobs?repo=try&revision=d420c82dbd6f81e67724b249adda13d62feea42e
https://treeherder.mozilla.org/#/jobs?repo=try&revision=eb6005c43f1770f9f4350d81112801b93688c1f8

New R4 failure on Linux. Reftest analyzer shows significant differences, not just fuzz. Regression range:

* 7f2fbdb6 Auto merge of #1595 - glennw:rtt6, r=kvark
* 9fd557f5 Refactor and optimize the render task tree.
Depends on: 1393055
Gonna land this.
Alias: wr-future-update
Assignee: nobody → bugmail
No longer depends on: 1393055
Summary: Future webrender update bug → Update webrender to 310af2613e7508b22cad11e734b8c47e66447cc7
Version: unspecified → 57 Branch
Here's another try push on top of bug 1393461.
Comment on attachment 8900736 [details]
Bug 1391614 - Update webrender to commit 310af2613e7508b22cad11e734b8c47e66447cc7.

https://reviewboard.mozilla.org/r/172190/#review177436
Attachment #8900736 - Flags: review?(jmuizelaar) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bbddacd6f132
Update webrender to commit 310af2613e7508b22cad11e734b8c47e66447cc7. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/bbddacd6f132
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.