Closed Bug 1391625 Opened 2 years ago Closed 2 years ago

Sidebar items spacing should change according to "Density" option

Categories

(Firefox :: Bookmarks & History, defect, P3)

57 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1389094
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- wontfix

People

(Reporter: baron, Unassigned)

References

Details

(Keywords: regression, ux-consistency, ux-minimalism)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170818100226

Steps to reproduce:

Open sidebar for bookmarks or history.


Actual results:

The spacing between items, as of 8/17, got much larger. My bookmarks now run off the bottom of the screen, and it is hard to scroll down. I had them carefully arranged so that they would all fit.


Expected results:

The spacing should not have changed.

There are addons to fix this, but they are no longer compatible with Nightly, and userChrome seems not to be supported anymore, although I have not tried just creating it. I should not have to do this, though. This extra spacing is harmful, not helpful.
Component: Untriaged → Bookmarks & History
Unfortunately, looks like it's intentional per bug #1391625,
maybe the spacing between Bookmark item Icon and Label should change according to chosen density option,
so in compact mode the spacing will be much smaller.

@ Stephen Horlander [:shorlander] - What do you think about this?
Blocks: 1391331
Flags: needinfo?(shorlander)
Also patch from bug #1388699 will add more space again, so adding that bug too.
And it could be caused by patch from bug #1388700, not from patch from bug #1391331.
Blocks: 1388699
Has Regression Range: --- → yes
Has STR: --- → yes
Summary: sidebar spacing too large → Sidebar spacing too large
Whiteboard: [photon-visual] [triage]
Changing title from "Sidebar spacing too large"
to "Sidebar/Toolbar spacing should change according to "Density" option"
to catch all space, as it also should change, same as button sizes and spacing between tab bar, location bar and bookmarks toolbar,
because in other way it will odd, that e.g. everything is compacted in "Compact" density mode, except only bookmark button items and their spaces are not.
Blocks: 1388700
Severity: normal → major
Keywords: ux-consistency
OS: Unspecified → All
Hardware: Unspecified → All
Summary: Sidebar spacing too large → Sidebar/Toolbar items spacing should change according to "Density" option
No longer blocks: 1388699, 1388700, 1391331
Depends on: 1388699, 1388700, 1391331
Whiteboard: [photon-visual] [triage]
Summary: Sidebar/Toolbar items spacing should change according to "Density" option → Sidebar/Toolbar/Menu items spacing should change according to "Density" option
No longer depends on: 1397086
Duplicate of this bug: 1397086
what's the status and priority of this?
Flags: needinfo?(jhofmann)
This bug seems to have originally been about the bookmarks sidebar and we should keep it at that. The bookmarks toolbar already adjusts to UI density.

Making the sidebar adjust to UI density is not in scope for Photon MVP, though I personally think it's a good idea and we should pursue it eventually, as we've gotten a lot of positive feedback on UI density as a general concept.

But yeah, unfortunately not in scope for 57/Photon.
Flags: needinfo?(jhofmann)
Summary: Sidebar/Toolbar/Menu items spacing should change according to "Density" option → Sidebar items spacing should change according to "Density" option
Severity: major → normal
Priority: -- → P3
Ah, I'm already working on this in bug 1389094. I'll dupe this one.
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(shorlander)
Resolution: --- → DUPLICATE
Duplicate of bug: 1389094
No longer blocks: photon-touch
This bug was not resolved. The original problem was that the bookmark menu spacing was too large. The problem arose because the "zoom page" add-on stopped working, and I had to use layout.css.devPixelsPerPx in order to make pages readable. This applied to the sidebar as well as the page content, and the bookmarks sidebar became un-usable.

The problem has now been solved by the "zoom" add-on. It is a little annoying that this bug was just subsumed into other bugs that had nothing do do with the original problem. Let's hope this add-on continues to work.
Thanks for clarifying Jonathan. If the add-on stops working we can reopen the bug. 
It also looks like this wasn't fixed in the maybe-not-duplicate bug in 57.
You need to log in before you can comment on or make changes to this bug.