Port Bug 945627. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey.

RESOLVED FIXED in seamonkey2.54

Status

enhancement
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.54
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 fixed, seamonkey2.54 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #945627 +++

Bug 393246 obsoleted FIXUP_FLAG_USE_UTF8.

Bug 945627 removed it from the source tree. It is still referenced in SeaMonkey source code.
Attachment #8898822 - Flags: review?(iann_bugzilla)
Status: NEW → ASSIGNED
Comment on attachment 8898822 [details] [diff] [review]
1391665-isUTF8.patch

LGTM r=me
Attachment #8898822 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/fd780befc796
Port Bug 942657. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.54
Comment on attachment 8898822 [details] [diff] [review]
1391665-isUTF8.patch

[Approval Request Comment]
Regression caused by (bug #): 942657
User impact if declined: none I just like to be tabbrowser.xml to be "nice and clean". It references an undefined variable here.
Testing completed (on m-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none
Attachment #8898822 - Flags: approval-comm-esr52?
Attachment #8898822 - Flags: approval-comm-beta?
Summary: Port Bug 942657. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey. → Port Bug 945657. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey.
Summary: Port Bug 945657. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey. → Port Bug 945627. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey.
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/06cf296b7904
Backed out changeset: fd780befc796 for referencing the wrong bug in the comment.
https://hg.mozilla.org/comm-central/rev/88f097d5e664
Port Bug 945627. Remove FIXUP_FLAG_USE_UTF8 in SeaMonkey. r=IanN
Comment on attachment 8898822 [details] [diff] [review]
1391665-isUTF8.patch

a=me for both repos
Attachment #8898822 - Flags: approval-comm-esr52?
Attachment #8898822 - Flags: approval-comm-esr52+
Attachment #8898822 - Flags: approval-comm-beta?
Attachment #8898822 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.