Implement new semantics for Stage 3 async interation

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
P3
normal
RESOLVED WORKSFORME
8 months ago
5 months ago

People

(Reporter: Leo Balter, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox57 fix-optional)

Details

(Whiteboard: [js:correctness])

(Reporter)

Description

8 months ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/57.0.2987.110 Safari/537.36

Steps to reproduce:

Respective test262 files:

test/language/expressions/async-generator/named-yield-promise-reject-next-yield-star-async-iterator.js
test/language/expressions/async-generator/yield-promise-reject-next-yield-star-async-iterator.js
test/language/expressions/class/async-gen-method-static-yield-promise-reject-next-yield-star-async-iterator.js
test/language/statements/for-await-of/async-gen-decl-dstr-array-elem-iter-rtrn-close-null.js
test/language/statements/for-await-of/async-gen-decl-dstr-array-elem-trlg-iter-rest-nrml-close-skip.js

Updated

8 months ago
Blocks: 1331092, 1352312
status-firefox57: --- → fix-optional
Priority: -- → P3
Whiteboard: [js:correctness]
Looks like this got fixed already. All tests mentioned in comment #0 succeed for me when testing locally.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.