If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] View menu shouldn't use a submenu for Show/Hide

VERIFIED WONTFIX

Status

SeaMonkey
General
--
enhancement
VERIFIED WONTFIX
16 years ago
13 years ago

People

(Reporter: Ken Harris, Assigned: Matthew Paul Thomas)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.9+)
Gecko/20020422
BuildID:    2002042203

The View menu has a submenu "Show/Hide", under which all the
toolbars live.  This shouldn't be a submenu: they should be in
the view menu itself.

Reproducible: Always
Steps to Reproduce:
1. Start Moz
2. Pull down the View menu


Actual Results:  Can't see what's available to show/hide: they're in a submenu,
so you have to select View -> Show/Hide -> Personal Toolbar
(for example).

Expected Results:  The items should be in the main menu:

View
   Hide Navigatior Toolbar
   Show Personal Toolbar
   Show Site Navigatior Bar
   Hide Status Bar
   Show Component Bar
   ---
   Show Sidebar
   ---
   Stop
   Reload
   ...

This reduces the mouse-acrobatics to change something, and lets
you see at a glance exactly what's available/turned on.

(Bug 103417 is related: it talks about removing the site nav bar
sub-sub-menu.)

I don't seem to have any applications around that dump Show/Hide
into a submenu: they all just put them in the View menu.

The Mac Human Interface Guidelines don't seem to address menu vs.
submenu, but they do say to use the unambiguous terminology
"Show Toolbar" / "Hide Toolbar" (is that a separate bug?).

If they were all just listed, it'd be 14 items instead of 9, which
I think is still perfectly reasonable.  (Illustrator's View menu is
25 items -- not that it's the example of a perfect app, but even at
14 we wouldn't be anywhere near the longest.)
then the menu could get very long - not such a good idea imho
Severity: minor → enhancement
Summary: View menu shouldn't use a submenu for Show/Hide → [RFE] View menu shouldn't use a submenu for Show/Hide
(Reporter)

Comment 2

16 years ago
Why, is somebody planning to add a lot of entries to the Show/Hide
submenu?  Not in any spec I can find...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
I think the commands should indicate the visibility of a toolbar (or whatever)
with a checkmark and not by using 'Show' or 'Hide' (it's easier to tell what's
enabled at a glance and it keeps the length of the menu items consistent).
(Reporter)

Comment 4

16 years ago
Ok.  I think I'd be fine with the current checkmark-style menuitems,
if they were in the main View menu.  (Apple's HIG say to use Show/Hide,
but I don't feel very strongly about that one way or the other.)

Comment 5

15 years ago
There are 6 items in this menu by default.  We can't stick them all in the top
level menu or it'd be ridiculously long.  But there's no need to, anyway -- how
often do people show and hide toolbars that they need such quick access?  Not
too often, I'd guess.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

15 years ago
There are only 9 items in the main View menu right now; what's the
"ridiculously long" threshold?  I can point to a bunch of common, popular
programs with more than 15 menuitems that are much nicer to work with than
Mozilla because they don't insist of putting everything in submenus.

Does mozilla.org have a UI spec that says how many menuitems may be in a menu?
The File menu has 13, so 13 is ok, but 15 is ridiculous?

IE 5.2 happens to have 15 items in the View menu, including all of the
optional toolbars, right in the main menu.  It's much more pleasant to use
when I'm at a desk with a mouse; when I'm using my laptop away from a desk,
it's virtually impossible to select that submenu with the trackpad (because
it's right below the menubar, I think), so I don't even bother.

When the UI is so hard to use even programmers are avoiding the most basic
features, something's very wrong.

Comment 7

15 years ago
I guess you're using IE on Mac.  I'm using the IE that most of the world is
using (5.0/6.0 on Windows) and the View menu has 11 items, and the toolbars are
in a Show/Hide menu.  If you're showing and hiding toolbars more than, say,
once, ever, you're an edge case.  Feel free to make an .xpi to do this.
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.