All users were logged out of Bugzilla on October 13th, 2018

SELECT element's "options" array not reflected into JavaScript

VERIFIED FIXED

Status

()

P2
normal
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: angus, Assigned: pollmann)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Simple test case:

<select onmouseup="alert(this.options[this.selectedIndex].id)">
<option id="one">One
<option id="two">Two
<option id="three">Three
</select>

11-16-98 12pm optimized build.
(Reporter)

Comment 1

20 years ago
*** Bug 1393 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Assignee: bogus → karnaze
(Reporter)

Updated

20 years ago
Assignee: karnaze → pollmann
(Reporter)

Comment 2

20 years ago
Actually, Eric is now the forms guru.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 3

20 years ago
The "options" array is reflected correctly.  For example

<select size=3 onmouseup="dump(this.options[1].id)">
<option id="one">One
<option id="two">Two
<option id="three">Three

The culprit in the first example is that the selectedIndex always returns -1
(indicating that no elements are selected)

I'll work on getting that corrected...
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

20 years ago
Just checked in a fix.

Updated

20 years ago
QA Contact: 4079

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 5

20 years ago
verified in 3/1 build.
You need to log in before you can comment on or make changes to this bug.