Add a normal icon to every Firefox Nightly release

RESOLVED DUPLICATE of bug 1389770

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1389770
10 months ago
10 months ago

People

(Reporter: pomax, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

10 months ago
I couldn't find a Nightly component/product, so I filed this under general Firefox, but it's really specifically for nightly. It's also not a happy bug report, so here goes:

I'm sure some people find it hilarious that the Firefox nightly icon now changes every week it seems, but it's a terrible thing for people who rely on visual identification to run applications. Changing the icon means making what these people got used to as the shortcut to Firefox Nightly invisible to them, and they end up confused as to where their product is even when someone who doesn't will go "it's right there, look, the icon says 'firefox nightly' and everything".

This is doing a disservice to actual people who have been all but ordered to use Nightly for the benefit of a cute joke, so: can we please also always bundle in the normal Nightly icon, and add a pref that allows people to opt out of this icon changing mallarky? Yes, it's stupid that I can't recognise an application when its icon changes, even when the name and position in my list of icons stays the same. I'm not happy about it either. But I have to live with that, and the current willy-nilly icon updates are a constant reminder that I am broken. 

Not a fan.

Comment 1

10 months ago
This (a bug database) is not a good place for feedback like this ("I don't like your joke" or "I think the way you're making this joke is counterproductive" or however you want to phrase it).

Your report gets seen by people who are simply triaging actual issues with software (and have to wade through unrelated stuff like this), and not by the people who came up with these jokes or the manner of making them. If you don't already know how to find a better place to make your concerns heard (including also subtext on things like "people who have been all but ordered to use Nightly"), please find out some other way than by filing bugs in bugzilla (e.g. by asking colleagues or your manager, checking the org chart, etc.).

In any case, my understanding is there will not be more icon changes later this week once the 'regular' nightly icon is back (and the only reason I know is because I asked folks involved because I'm tired of the complaints on bugzilla - I thought the icons were fun, but to each their own, I guess).
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389770

Comment 2

10 months ago
(In reply to :Gijs from comment #1)
> This (a bug database) is not a good place for feedback like this ("I don't
> like your joke" or "I think the way you're making this joke is
> counterproductive" or however you want to phrase it).

Not wanting this kind of feedback is OK, but then please update https://bugzilla.mozilla.org/page.cgi?id=etiquette.html, I think this sentence needs to be removed:

> Constant and intense critique is one of the reasons we build great products.
> It's harder to fall into group-think if there is always a healthy amount of dissent.
> We want to encourage vibrant debate inside of the Mozilla community, we want you to
> disagree with us, and we want you to effectively argue your case.

Effectively I think the folks involved are falling into group-thinking that the logo changes are fun, without realizing that it breaks the workflow of the Nightly user base.

Comment 3

10 months ago
(In reply to Oriol Brufau [:Oriol] from comment #2)
> (In reply to :Gijs from comment #1)
> > This (a bug database) is not a good place for feedback like this ("I don't
> > like your joke" or "I think the way you're making this joke is
> > counterproductive" or however you want to phrase it).
> 
> Not wanting this kind of feedback is OK, but then please update
> https://bugzilla.mozilla.org/page.cgi?id=etiquette.html, I think this
> sentence needs to be removed:
> 
> > Constant and intense critique is one of the reasons we build great products.
> > It's harder to fall into group-think if there is always a healthy amount of dissent.
> > We want to encourage vibrant debate inside of the Mozilla community, we want you to
> > disagree with us, and we want you to effectively argue your case.
> 
> Effectively I think the folks involved are falling into group-thinking that
> the logo changes are fun, without realizing that it breaks the workflow of
> the Nightly user base.

But I am not one of the "folks involved", and neither are the other people I've seen dealing with the bug fallout. This isn't about groupthink, it's about finding the right channel for feedback. No point trying to challenge alleged "groupthink" by talking to a different group.
(Reporter)

Comment 4

10 months ago
Perhaps I wasn't clear: this is an accessibility bug, not "I don't like your joke". Obviously I don't like your joke, but tht's not the issue, the issues is that I don't like your joke because I have a disability and this joke means I can't find the version of firefox that I've been ordered to use by MoCo management until I retrain my brain on the new icon for _several days_.

We care about accessiblity: this is a bug that should be reopened and addressed by adding the normal nightly icon as a stable icon that can be set so that the for many people funny, but for some people drastically-accessibility-ruining functionality of changing the icon does not impact all the folks who've been ordered by management to use this product in their daily work at Mozilla.

Comment 5

10 months ago
(In reply to Mike "Pomax" Kamermans [:pomax] from comment #4)
> by adding the normal nightly icon as a stable icon that can be set
> so that the for many people funny, but for some people
> drastically-accessibility-ruining functionality of changing the icon does
> not impact all the folks who've been ordered by management to use this
> product in their daily work at Mozilla.

This is not technically possible. Prefs are in your profile. The app icon (certainly as stored on the dock / start menu / etc.) is an application-level feature. It cannot change based on prefs in your profile. There is external tooling available, so on Windows you can select a custom shortcut icon ( Right click any shortcut, Properties, Change Icon... ) and on OS X you can also change it ( File->Get Info on the icon in Finder, you can drag drop any icon onto Firefox and it will change it )

In any case, as I mentioned in comment #1, my understanding is that the 'regular' nightly icon will be back (and will then stay) shortly.
(Reporter)

Comment 6

10 months ago
Perhaps I was unclear: this is an accessiblity bug, not an "I don't like your joke" report. Obviously I don't seem to appreciate the joke, but the *reason* is why I filed a bug. I don't want you to stop messing with the icon, as long as for accessibility purposes there is a way to turn off the dynamic nature of the icon.

This is most definitely a bug, because we care about accessibility in firefox, and the decision to land patches that change the icon apparently didn't run by an accessibility check (that happens more often than we all want, and isn't anyone's "fault" but does need addressing after the fact), or we did consider accessiblity but no one realised the effect this could have (also entirely possible, also no one at fault, also something that needs addressing after the fact). 

As it stands, a patch landed that drastically decreased the usability of the product for some people (like me) who can end up spending a full minute trying to find an application that is "right there" but our brain literally can't see because it doesn't recognize it. That's easy enough to fix with an about:config pref that lets users who have this problem make sure that the icon remains stable, and is an accessibility bug that needs to be addressed, revealed by the recent "several icon changes over a short period of time".

> I'm tired of the complaints on bugzilla

The way I read your response, it felt like you saw the first few words and went "this is a complaint" and then stopped reading, rather than reading the whole thing and realising "oh wait, no it's not, this is a genuine accessibility bug". It's unfortunate that happened.

> my understanding is there will not be more icon changes later this week once the 'regular' nightly icon is back 

That's great to hear from a daily use perspective for people like me. Hopefully that does not change the fact that without a fix here, the potential for exactly the same situation is still there, and merits this bug still getting addressed. Future nightly users with disabilities should not need to be impacted by a repeat if one ever occurs.

Comment 7

10 months ago
(In reply to Mike "Pomax" Kamermans [:pomax] from comment #6)
> That's easy enough to fix with an
> about:config pref that lets users who have this problem make sure that the
> icon remains stable, and is an accessibility bug that needs to be addressed,
> revealed by the recent "several icon changes over a short period of time".

I already addressed this suggestion in comment #5. What you suggest is not possible.

For everything else, I really recommend you contact the appropriate a11y / design teams, as I have already done repeatedly. Continuing to comment in this bug is not going to help get this addressed, as the people who would need to read it likely aren't.
You need to log in before you can comment on or make changes to this bug.