Launching Chatzilla fails with error message NS_ERROR_XPC_BAD_CONVERT_JS

RESOLVED DUPLICATE of bug 1389449

Status

RESOLVED DUPLICATE of bug 1389449
a year ago
a year ago

People

(Reporter: RainerBielefeldNG, Unassigned)

Tracking

SeaMonkey 2.54 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [easyconfirm])

(Reporter)

Description

a year ago
Steps how to reproduce with unzipped installer of  official en-US SeaMonkey 2.54a1 (NT 6.1; WOW64; rv:57.0) Gecko/20100101 Firefox/57.0 Build 20170813013143  (Default Classic Theme, German Language Pack active) on German WIN7 64bit:

1. Launch SM
2. In Browser Status Bar click cZ icon for Chatzilla
   Expected: Chatzilla launches
   Actual: error message pops up

a) complete contents of error message:
NS_ERROR_XPC_BAD_CONVERT_JS: Could not convert JavaScript argument arg 0 [nsISupports.QueryInterface] @ <chrome://chatzilla/content/lib/js/pref-manager.js> 52
PrefManager@chrome://chatzilla/content/lib/js/pref-manager.js:52:9
initPrefs@chrome://chatzilla/content/prefs.js:16:26
init@chrome://chatzilla/content/static.js:126:5
onLoad@chrome://chatzilla/content/handlers.js:56:9
onload@chrome://chatzilla/content/chatzilla.xul:1:1

+ toString (function) 3 lines
+ message (string) 'Could not convert JavaScript argument arg 0 [nsISupports.QueryInterface]'
+ result (number) 2153185289
+ name (string) 'NS_ERROR_XPC_BAD_CONVERT_JS'
+ filename (string) 'chrome://chatzilla/content/lib/js/pref-manager.js'
+ lineNumber (number) 52
+ columnNumber (number) 0
+ data (object) null
+ stack (string) 270 chars
+ location (object)
*
(Reporter)

Comment 1

a year ago
b) Works fine with unzipped installer of  official en-US SeaMonkey 2.53a1 (NT 6.1; WOW64;
   rv:56.0) Gecko/20100101 Firefox/56.0 Build 20170720014833  
  (Default Classic Theme, German Language Pack active) on German WIN7 64bit
Was fixed on 08/17.

You might need to manually install it because the version number didn't change. Not sure if it is picked up when installing a new 2.54a1.

Please reopen if not fixed in later builds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1389449
You need to log in before you can comment on or make changes to this bug.