scrolling arrows appear on submenus of context menu when they are not needed

VERIFIED DUPLICATE of bug 135076

Status

()

Core
XUL
VERIFIED DUPLICATE of bug 135076
16 years ago
10 years ago

People

(Reporter: Dean Tessman, Assigned: David Hyatt)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This has been discussed in bug 84121, but I think we may need a separate bug to
track this issue.  This has become a more urgent problem due to the
ever-so-lovely "This Frame" context sub-menu in the recent context menu redesign.

1. Go to a page with frames (eg. http://www.generalcoffee.com)
2. Ensure your browser window is near the bottom of your screen
3. Right-click near the bottom of the window
4. Select "This Frame" menu item

Expected Results: Sub-menu displays with all items visible

Actual Results: Sub-menu displays with View Frame Info item missing and scroll
arrows visible.  Note that after this, clicking higher up in the window and
selecting the sub-menu will display the context menu with all items visible, but
the scroll arrows still appear.
Sounds like mozilla1.0 fodder.  Any hope of a patch?

/be
Blocks: 138000
Keywords: mozilla1.0+

Comment 2

16 years ago
I found this bug in the Table Insert/Select/Delete submenus.  The submenu size
always appears to be exactly one line too short, causing the scroll bars to
appear.  I hadn't noticed until I read this bug that when the menu is opened in
the middle of the screen, all items are displayed but the scroll bars still
appear.  Of course both these behaviors are incorrect.

*** This bug has been marked as a duplicate of 135076 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

16 years ago
Whoops, missed that one.  Verified Dupe.
Status: RESOLVED → VERIFIED

Comment 5

16 years ago
removing rc2 keyword.
No longer blocks: 138000

Updated

16 years ago
Blocks: 138000

Comment 6

16 years ago
removing dependency
No longer blocks: 138000

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.