Firefox download dialog shows target site, but not originating site

RESOLVED DUPLICATE of bug 1306339

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 1306339
5 months ago
5 months ago

People

(Reporter: atoll, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 months ago
Created attachment 8899505 [details]
Was this download initiated by docs.google.com or badsite.example.com?

If I click "Download file" in one tab and then switch to another tab, the download dialog from the first tab opens above my current tab, but shows me only the final CDN hostname of my download.

Please consider either including information about which tab initiated download was started by somehow — or consider making this a per-tab, non-modal dialog.

Updated

5 months ago
Component: General → Downloads Panel

Comment 1

5 months ago
This dialog will disappear in bug 1306339, and for the cases where we need to ask for permission as indicated in bug 1306334 there will be a per-tab, non-modal prompt.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1306339
You need to log in before you can comment on or make changes to this bug.