Color Properties Not Displayed Correctly with Dual Monitors

UNCONFIRMED
Unassigned

Status

Thunderbird
Message Compose Window
UNCONFIRMED
4 months ago
4 months ago

People

(Reporter: Scott, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8899637 [details]
Thunderbird Color Properties Bug.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170814072924

Steps to reproduce:

Have a dual monitor computer setup.

1.	Open Thunderbird.
2.	Make sure that thunderbird is only using 1 screen.
3.	Start writing an email.
4.	In the Compose Window, type in some text.
5.	Select the text, then click the Choose Color for Text / Choose Color for Background from the either the Formatting toolbar or the Format menu.




Actual results:

The dialog that is shown is centered, but spans onto both monitors (half shown on the Primary Screen and half on the Secondary Screen).


Expected results:

It should be shown on the Current Monitor, and Not spanned over 2 monitors.
(Reporter)

Comment 1

4 months ago
NOTE:  This bug ONLY happens when The Compose Email (Write Email) window is on the Secondary Screen.

Comment 2

4 months ago
Looks like it is displayed centred.

Richard, any interest in this?
Flags: needinfo?(richard.marti)
Here I can move the color dialog to a other position. After closing and opening it again the dialog is at the last position. Also closing TB let the position persist.

Scott, please can you check, if after moving and closing the dialog, it opens at the last position? If not, could you try the same with all extensions disabled (see help menu)?
Flags: needinfo?(richard.marti) → needinfo?(smhiker)
(Reporter)

Comment 4

4 months ago
I tried it by manually moving the color dialog (& pressing OK), then re-opened the Color dialog, it opens again in the center of the 2 screens.  I also tried it with all the Add-ons Disabled, it had the same result.
Flags: needinfo?(smhiker)
Okay, and this is the only TB dialog which behaves like this? You tried the other insert dialogs?

What graphics card/driver are you using?
You need to log in before you can comment on or make changes to this bug.