Closed Bug 1392535 Opened 2 years ago Closed 2 years ago

Update GMP fallback downloader for Widevine 1008 CDM

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: JamesCheng, Assigned: JamesCheng)

References

Details

Attachments

(2 files)

In bug 1388771, we're aiming to pushing out a new Widevine CDM. We need to update the downloader fallback to reflect the new CDM's URLs.

We are targeting on 1008 CDM but should fix the blocker Bug 1392485 first.

The 984 CDM is the alternative once the sandbox issue cannot be resolved in time.
python script to calculate the hashes and length(reference the script from cpearce)

Paste the output of the script.

  Targeting CDM version 1.4.8.1008 
     "Linux_x86-gcc3": {
       "fileUrl": "https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-linux-ia32.zip",
       "hashValue": "5af0f41dddf3077c2977a775a3009c435569892f7efa2110932424fda3556d6ecee76fbb1e9633e72b72e09a92b0b7fa2ac159e1741b0d4cd94e095b6e121bce",
       "filesMy python script to calculate the hashes and lengthize": 2289324
     },
     "Linux_x86_64-gcc3": {
       "fileUrl": "https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-linux-x64.zip",
       "hashValue": "37e037a5e0c320a6a577492050d86b2bbd00239610785b0f07326e6c47b6d1899ac4f6874ad1436982a95a13c11fd73e10e9287d88da0c1036dd6eb36fe91e65",
       "filesize": 2207964
     },
     "Darwin_x86_64-gcc3-u-i386-x86_64": {
       "fileUrl": "https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-mac-x64.zip",
       "hashValue": "950b2e1e74dc685294540e2969050a5558e9314d17a122b38b61de35897e692da247bff820fa3df721c607b38aa3bd95f36f7d4da83fb11a67ec9b1198890be8",
       "filesize": 1755276
     },
     "WINNT_x86-msvc": {
       "fileUrl": "https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-win-ia32.zip",
       "hashValue": "4630796cf6e5cc832317bf07bcda70f46432111d0bb381da9e2ebf9350cbac7790d6db1c34c7e3bced774a9b7811310cf21011fccbff779ac76d237505b5f117",
       "filesize": 2544372
     },
     "WINNT_x86_64-msvc": {
       "fileUrl": "https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-win-x64.zip",
       "hashValue": "2c3ebe3a5c3fa62e2fb2e41080d576c71fa060cb81ef415815652a020bb3da16de28d9a2d0d5af4f71df920abd159d6c3cf27ebdd1d65daf62cee6282f9def85",
       "filesize": 2537223
     },


Linux 32bit
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-linux-ia32.zip
SHA512: 5af0f41dddf3077c2977a775a3009c435569892f7efa2110932424fda3556d6ecee76fbb1e9633e72b72e09a92b0b7fa2ac159e1741b0d4cd94e095b6e121bce
FileSize: 2289324

Linux 64bit
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-linux-x64.zip
SHA512: 37e037a5e0c320a6a577492050d86b2bbd00239610785b0f07326e6c47b6d1899ac4f6874ad1436982a95a13c11fd73e10e9287d88da0c1036dd6eb36fe91e65
FileSize: 2207964

MacOS 10.9+
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-mac-x64.zip
SHA512: 950b2e1e74dc685294540e2969050a5558e9314d17a122b38b61de35897e692da247bff820fa3df721c607b38aa3bd95f36f7d4da83fb11a67ec9b1198890be8
FileSize: 1755276

Windows 7+ 32bit
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-win-ia32.zip
SHA512: 4630796cf6e5cc832317bf07bcda70f46432111d0bb381da9e2ebf9350cbac7790d6db1c34c7e3bced774a9b7811310cf21011fccbff779ac76d237505b5f117
FileSize: 2544372

Windows 7+ 64bit
URL: https://redirector.gvt1.com/edgedl/widevine-cdm/1.4.8.1008-win-x64.zip
SHA512: 2c3ebe3a5c3fa62e2fb2e41080d576c71fa060cb81ef415815652a020bb3da16de28d9a2d0d5af4f71df920abd159d6c3cf27ebdd1d65daf62cee6282f9def85
FileSize: 2537223
Comment on attachment 8899767 [details]
Bug 1392535 - Update GMP fallback downloader for Widevine 1008 CDM.

Hi Mike,

We would like your help on reviewing this JSON.
I know you are on PTO but I don't know who can review this patch alternatively
, it is ok to review this patch by next week.
So I just set ni? to inform you.
We would land this patch once Bug 1388771 has been resolved.

Thank you.
Flags: needinfo?(mconley)
The Balrog rule has been updated on Nightly by Bug 1388771, so this patch is ready to be landed once it got r+.
Comment on attachment 8899767 [details]
Bug 1392535 - Update GMP fallback downloader for Widevine 1008 CDM.

https://reviewboard.mozilla.org/r/171106/#review181336

rs=me. Seems okay - though I didn't do the hash generation myself to verify the hashes.

Thanks!
Attachment #8899767 - Flags: review+
Flags: needinfo?(mconley)
Pushed by jacheng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91593cfd741b
Update GMP fallback downloader for Widevine 1008 CDM. r=mconley
Thank you, the hash is correct since the Balrog rule in up to date and user can get the correct CDM.

I will do an uplifting requesting.
Comment on attachment 8899767 [details]
Bug 1392535 - Update GMP fallback downloader for Widevine 1008 CDM.

Approval Request Comment
[Feature/Bug causing the regression]:Widevine CDM version 1008 update to Beta >=8
[User impact if declined]: Users have chance that they are not able to download CDM when AUS server is down.
[Is this code covered by automated tests?]:No
[Has the fix been verified in Nightly?]:No
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: Only this patch.
[Is the change risky?]:No
[Why is the change risky/not risky?]:It's just an alternative.
[String changes made/needed]:No
Attachment #8899767 - Flags: approval-mozilla-beta?
https://hg.mozilla.org/mozilla-central/rev/91593cfd741b
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8899767 [details]
Bug 1392535 - Update GMP fallback downloader for Widevine 1008 CDM.

Update GMP fallback downloader for Widevine 1008 CDM. Beta56+.
Attachment #8899767 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(In reply to James Cheng[:JamesCheng] from comment #8)
> [Needs manual test from QE? If yes, steps to reproduce]: No

Setting qe-verify flag to - , per James's assessment on manual assessment needs.
Flags: qe-verify-
See Also: → 1414734
You need to log in before you can comment on or make changes to this bug.