Closed Bug 1392588 Opened 2 years ago Closed 2 years ago

Search icon is still displayed in the search field when typing

Categories

(Firefox :: Preferences, defect)

57 Branch
defect
Not set

Tracking

()

RESOLVED INVALID
Tracking Status
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- affected

People

(Reporter: hani.yacoub, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image search icon.png
[Affected versions]: 
Nightly 57.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox.
2. Go to "about:preferences".
3. Start typing in the search field.

[Expected result]:
Hide search icon when typing.

[Actual result]:
Search icon is still displayed in the search field when typing
Blocks: 1357306
Whiteboard: [photon-preference]
According to latest visual spec https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/244683024, focus & filled (typing) status will stay the search icon as it is.

Looks like the spec has changed recently so this issue might be wrong.

Hani, can you confirm that you're looking at the right link (https://mozilla.invisionapp.com/share/X8BGCX9PD#/screens/244683024)?

Thanks
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(hani.yacoub)
Resolution: --- → INVALID
I was looking at the right link.
But I red the note under search icon where it's said clearly "Hide search icon when typing".
Flags: needinfo?(hani.yacoub)
hi Helen,

please provide updated visual spec.
Flags: needinfo?(hhuang)
Sure! The spec is updated, link here https://mozilla.invisionapp.com/share/X8BGCX9PD#/244683024_Search_In_Preferences
Flags: needinfo?(hhuang)
remove whiteboard tag due to its INVALID based on latest spec
Whiteboard: [photon-preference]
You need to log in before you can comment on or make changes to this bug.