The search bar collides with other icons in the customize panel

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
3 months ago
3 months ago

People

(Reporter: David Naylor, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
Created attachment 8899827 [details]
searchbar-bug.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170821100350

Steps to reproduce:

Right-clicked Firefox toolbar -> Customize. Dragged search bar off the toolbar and into the customize window panel.


Actual results:

The search bar, when resting among the unused buttons / icons, gets covered by the next icon to the right.


Expected results:

The search bar should push the next icon away to the right, maintaining the correct spacing.
(Reporter)

Updated

3 months ago
Component: Untriaged → Toolbars and Customization
(Reporter)

Comment 1

3 months ago
Setting importance to "blocker" since I doubt Firefox 57 can ship with this bug.
Severity: normal → blocker

Comment 2

3 months ago
(In reply to David Naylor from comment #1)
> Setting importance to "blocker" since I doubt Firefox 57 can ship with this
> bug.

That's not how release blocking works on this bugtracker, so I've reverted this and requested tracking for this release.

(In reply to David Naylor from comment #0)
> Right-clicked Firefox toolbar -> Customize. Dragged search bar off the
> toolbar and into the customize window panel.
> 
> 
> Actual results:
> 
> The search bar, when resting among the unused buttons / icons, gets covered
> by the next icon to the right.

I can't reproduce this, testing with the same nightly, also on win10. Can you reproduce on a clean profile? ( https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles )

Also, this looks like a localized build. If you can reproduce on a clean profile, can you check if you can reproduce on an en-US build? In some cases we allow localizations to set sizes for things (because different languages sometimes need more / less space for a given label), and I'm curious if that plays a role here.
Severity: blocker → normal
tracking-firefox57: --- → ?
Flags: needinfo?(naylor83)

Updated

3 months ago
Priority: -- → P4
Whiteboard: [reserve-photon-structure]

Updated

3 months ago
Flags: qe-verify+
QA Contact: gwimberly
(Reporter)

Comment 3

3 months ago
Trying to reproduce at home. Tried clean profile with sv-SE locale, no problem there. Tried my regular profile with addons both disabled and enabled, no problem there either. 

Will try again on my work laptop, where I originally saw this weirdness. Presumably some extension causing it, I guess.
Flags: needinfo?(naylor83)
(Reporter)

Comment 4

3 months ago
In safe mode (addons disabled) the problem is gone on my work laptop as well. Setting RESOLVED WFM. Sry for not testing this properly to begin with.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME

Comment 5

3 months ago
(In reply to David Naylor from comment #4)
> In safe mode (addons disabled) the problem is gone on my work laptop as
> well. Setting RESOLVED WFM. Sry for not testing this properly to begin with.

NP! Just to be really sure, I take it you're using non-webextension add-ons? If webextension add-ons can cause this we likely still need to fix it. :-)
Flags: needinfo?(naylor83)

Updated

3 months ago
Flags: qe-verify+
Priority: P4 → --
QA Contact: gwimberly
Whiteboard: [reserve-photon-structure]
(Reporter)

Comment 6

3 months ago
I tried to narrow down which extension was causing this, but I have now manually disabled all addons which were enabled to begin with (and restarted) and the bug still persists. There are also a number of legacy addons which have been automatically disabled.

The compatible addons that I have manually disabled are:
- Don't **** with paste
- Google search link fix
- Keepa - Amazon Price Tracker
- Secure Password Generator
- Show me the password! On focus
- snoozetabs
- Test pilot

The incompatible addons which were already automatically disabled:
- Context Search
- Den stora svenska ordlistan
- Dictionary Switcher
- Enable Tracking Protection
- enter-selects
- FindBar Tweak
- I don't care about cookies
- Lazarus: Form Recovery
- Pure URL
- Saved Password Editor
- Youtube High Definition
- Youtube without DASH Playback

Surely the automatically disabled addons are just as disabled as the manually disabled ones?

I'm also trying to think if I had some kind of width setting for the search bar in about:config, but I've searched for "width" and not found any setting that might be interfering.
Flags: needinfo?(naylor83)

Comment 7

3 months ago
If you copy xulstore.json from the profile where it's broken to a clean one (while Firefox is closed) and then start the formerly clean profile, can you reproduce there?
Flags: needinfo?(naylor83)

Comment 8

3 months ago
And yes, disabled == disabled.

If the xulstore.json thing doesn't turn something up, I wonder if you could use the browser toolbox ( https://developer.mozilla.org/en-US/docs/Tools/Browser_Toolbox ) to inspect what's going on and/or copy the relevant markup. Still curious how/when this is broken. It's still possible there's some edgecase we need to fix. :-)
(Reporter)

Comment 9

3 months ago
Thanks for the suggestions. I tried moving my old xulstore.json to a new profile, but things looked just fine (using the new profile).

I also tried enabling the browser toolbox and poking around in the inspector. Tried to look for any differences in the CSS code for the different nodes/objects in the customize panel, but I couldn't find anything at all that looked fishy. I looked at margins, display, float, and more. Not sure if I can copy anything that is meaningful, but here's the searchbar outer HTML:

<toolbarpaletteitem xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul" place="palette" id="wrapper-search-container" title="Search" tooltiptext="Search" flex="100" removable="true" context="customizationPaletteItemContextMenu"><toolbaritem id="search-container" title="Search" align="center" class="chromeclass-toolbar-additional panel-wide-item" flex="100" persist="width" removable="true"><searchbar id="searchbar" flex="1" addengines="true"/></toolbaritem></toolbarpaletteitem>

Let me know if there is anything more I can do. I will perhaps have another go at using the browser toolbox.
Flags: needinfo?(naylor83)
Adjusting tracking flag based on the on the resolution of this bug.
tracking-firefox57: ? → ---
You need to log in before you can comment on or make changes to this bug.