Most visited (highest frecency) pages should trump the search option in location bar suggestions

RESOLVED DUPLICATE of bug 1239708

Status

()

Firefox
Address Bar
--
enhancement
RESOLVED DUPLICATE of bug 1239708
3 months ago
3 months ago

People

(Reporter: David Naylor, Unassigned)

Tracking

57 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 months ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID: 20170821100350

Steps to reproduce:

I type "fa" into the location bar.


Actual results:

The top suggestion in the location bar dropdown is to search Google for "fa". To visit facebook.com I have to hit Tab or Arrow down, then Enter.


Expected results:

The top suggestion should be facebook.com, since it is among my most visited pages. This would save the user from having to hit Tab or Arrow down before hitting Enter.

The Google search item should be pushed down, either to number 2 or all the way down below the bookmarks & history hits to among the other search suggestions.

I'm not sure exactly where to draw the line for these super high frecency pages. It could either be done only for the top 10 most visited URLs, or it could be done for all pages with a frecency above a certain threshold.

The algorithm could also be made even more sophisticated by preferring high frecency hits especially for short strings, up to perhaps three characters: "fac" "you" "twi" etc.

I'm convinced this would be a major usability improvement and could potentially make the awesomebar even more of a killer Firefox feature.
(Reporter)

Updated

3 months ago
Severity: normal → enhancement
Component: Untriaged → Location Bar
(Reporter)

Comment 1

3 months ago
Just an added comment: For longer strings, actual search strings, the search option should (and will, according to the above logic) be suggested at the top. Thereby this improvement for top sites should not get in the way of people who actually want to conduct a search. We can have our cake and eat it!

Updated

3 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1239708
You need to log in before you can comment on or make changes to this bug.