[osx classic] scrollbar doesn't work in some outliners

VERIFIED FIXED in mozilla1.0

Status

()

--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: mikepinkerton, Assigned: mikepinkerton)

Tracking

({regression})

Trunk
mozilla1.0
PowerPC
Mac OS X
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ADT1])

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
for osx classic, the native scrollbar doesn't work with some outliners, notably
the one in the Download Manager. It's an ordering thing, we were initializing
our mediator before it had been fully hooked up. Delaying that action fixes it. 

patch upcoming.
(Assignee)

Comment 1

17 years ago
mail filter dialog was another one that didn't work.
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbeta1+, regression
Whiteboard: [ADT1]
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 2

17 years ago
Created attachment 80426 [details] [diff] [review]
delay hookup a little longer

looking for r/sr

Comment 4

17 years ago
Comment on attachment 80426 [details] [diff] [review]
delay hookup a little longer

r=sdagley
Attachment #80426 - Flags: review+

Comment 5

17 years ago
Please check this into the trunk and update the bug when it's tested.  Claudius
can you try this out when it's landed?
(Assignee)

Comment 6

17 years ago
mommy, may i?
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Keywords: adt1.0.0
Resolution: --- → FIXED

Comment 7

17 years ago
Claudius, can you test this and update the bug with the results.  Does this
change affect Windows and Linux, too?
(Assignee)

Comment 8

17 years ago
this is mac-only.

Comment 9

17 years ago
fyi, claudius is just waiting for a branch build that both has the fix AND runs.
(Assignee)

Comment 10

17 years ago
you won't get a branch build with this fix, because, um, they won't approve it
until you verify on the trunk....

sigh...

Comment 11

17 years ago
yeah well it turns out claudius doesn't read so well and was dutifully watching
the trunk tinderbox thinking it was the branch(so i thought pink checked in there).

This works with flying colors in a 2002042412 trunk build on MacOS X. The bug is
fixed and I couldn't find any regressions with scrolling elsewhere.

VERIFIED Fixed 2002042412 OSX(trunk) builds
Status: RESOLVED → VERIFIED

Comment 12

17 years ago
adt1.0.0+ (on ADT's behalf) approval for checkin into 1.0 branch. Pls check this
into the 1.0, after recieving  Drivers approval, then add the fixed1.0.0 keyword.
Keywords: approval
Whiteboard: [ADT1] → [ADT1] [Needs a=]
Comment on attachment 80426 [details] [diff] [review]
delay hookup a little longer

a=roc+moz for branch
Attachment #80426 - Flags: approval+
(Assignee)

Updated

17 years ago
Whiteboard: [ADT1] [Needs a=] → [ADT1]

Updated

17 years ago
Keywords: adt1.0.0 → adt1.0.0+

Comment 14

17 years ago
adding the adt1.0.0+ to go along with Jaime's approval.
(Assignee)

Comment 15

17 years ago
landed on 1.0 branch 4:31pm EDT 4/26/02
Keywords: adt1.0.0+ → fixed1.0.0
You need to log in before you can comment on or make changes to this bug.