Closed Bug 1392633 Opened 3 years ago Closed 3 years ago

Bookmark properties dialog has no background or titlebar

Categories

(Firefox :: Theme, defect, P1)

57 Branch
All
Windows
defect

Tracking

()

VERIFIED FIXED
Firefox 57
Iteration:
57.2 - Aug 29
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: agashlin, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

In current 64-bit Nightly on a clean profile on Windows 10:

1. Click menu -> library -> bookmarks
2. Right click on a bookmark and select properties

Properties window shows text edit boxes and labels, but no window background titlebar, or frame

Expected: Dialog appears as a normal Windows dialog, with background and window frame

mozregression:
INFO: Last good revision: ecc3f03e5eaed2a4908b5f1a14759585f9a0b01a
INFO: First bad revision: 3c5b27abffa754649bfcfde71f9516a930316d23
INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ecc3f03e5eaed2a4908b5f1a14759585f9a0b01a&tochange=3c5b27abffa754649bfcfde71f9516a930316d23

This seems to be related, then, to bug 1384504
Uhhh:


+++ b/browser/themes/windows/places/places.css
@@ -1,18 +1,31 @@
 /* This Source Code Form is subject to the terms of the Mozilla Public
  * License, v. 2.0. If a copy of the MPL was not distributed with this
  * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
 
 /* Sidebars */
+
+:root {
+  background-color: transparent;
+}
Blocks: 1384504
Flags: needinfo?(nhnt11)
Keywords: regression
Whiteboard: [photon-visual][triage]
(In reply to :Gijs from comment #1)
> Uhhh:
> 
> 
> +++ b/browser/themes/windows/places/places.css
> @@ -1,18 +1,31 @@
>  /* This Source Code Form is subject to the terms of the Mozilla Public
>   * License, v. 2.0. If a copy of the MPL was not distributed with this
>   * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
>  
>  /* Sidebars */
> +
> +:root {
> +  background-color: transparent;
> +}

Lol, sorry, I'm on it.
Assignee: nobody → nhnt11
Status: NEW → ASSIGNED
Flags: needinfo?(nhnt11)
Severity: normal → major
Has Regression Range: --- → yes
Has STR: --- → yes
OS: Unspecified → Windows
Hardware: Unspecified → All
Duplicate of this bug: 1392730
Duplicate of this bug: 1392718
Also the downloads menu.
Assignee: nhnt11 → dao+bmo
Priority: -- → P1
Whiteboard: [photon-visual][triage] → [reserve-photon-visual]
Comment on attachment 8899964 [details]
Bug 1392633 - Stop removing the background in non-sidebar documents using places.css.

https://reviewboard.mozilla.org/r/171290/#review176464
Attachment #8899964 - Flags: review?(nhnt11) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf3a6dfc75c2
Stop removing the background in non-sidebar documents using places.css. r=nhnt11
Iteration: --- → 57.2 - Aug 29
Flags: qe-verify+
QA Contact: ovidiu.boca
Duplicate of this bug: 1392646
Duplicate of this bug: 1392816
https://hg.mozilla.org/mozilla-central/rev/cf3a6dfc75c2
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Duplicate of this bug: 1393183
Duplicate of this bug: 1393316
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 57.0a1 (2017-08-24), so I'm marking this bug as VERIFIED. Thanks.
Status: RESOLVED → VERIFIED
QA Contact: ovidiu.boca → Virtual
Flags: qe-verify+
The title bar is fixed, but now there is an excessive white space on the right corner of History popup
http://i.imgur.com/hwvr1c9.png
(In reply to smartfon.reddit from comment #18)
> The title bar is fixed, but now there is an excessive white space on the
> right corner of History popup
> http://i.imgur.com/hwvr1c9.png

this is Bug 1393411
You need to log in before you can comment on or make changes to this bug.