Closed Bug 1392665 Opened 3 years ago Closed 3 years ago

Add missing permissions string NSPhotoLibraryAddUsageDescription

Categories

(Firefox for iOS :: General, enhancement, P1, critical)

Other
iOS
enhancement

Tracking

()

VERIFIED FIXED
Tracking Status
fxios 9.0 ---

People

(Reporter: aaronmt, Unassigned)

References

Details

(Keywords: crash, reproducible, Whiteboard: [Strings])

Attachments

(1 file)

Currently we crash on attempt to save an image. We do not prompt for permission to save to Photos.

=>Install Firefox 9.0 (5342)
=> Attempt to save an image

Exception Type:  EXC_CRASH (SIGKILL)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note:  EXC_CORPSE_NOTIFY
Termination Reason: TCC, This app has crashed because it attempted to access privacy-sensitive data without a usage description. The app's Info.plist must contain an NSPhotoLibraryAddUsageDescription key with a string value explaining to the user how the app uses this data.
Blocks: ios11
Summary: Crash on Save Image → Crash because of missing permissions string NSPhotoLibraryAddUsageDescription
Priority: -- → P1
Summary: Crash because of missing permissions string NSPhotoLibraryAddUsageDescription → Crash on Save Image
Summary: Crash on Save Image → Crash because of missing permissions string NSPhotoLibraryAddUsageDescription
Whiteboard: [Strings]
Summary: Crash because of missing permissions string NSPhotoLibraryAddUsageDescription → Add missing permissions string NSPhotoLibraryAddUsageDescription
Verified as fixed on latest master and v9.0(5607)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.