Closed Bug 1392822 Opened 2 years ago Closed 2 years ago

In onboarding tour "Library" section, button is labeled "Show Library in Menu" -- but instead highlights a toolbar button

Categories

(Firefox :: General, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox57 --- verified

People

(Reporter: dholbert, Assigned: Fischer)

References

Details

(Whiteboard: [photon-onboarding])

Attachments

(2 files)

In the 57 onboarding tour, in my main Firefox profile, there is a "Library" subsection, which has a button:
 "Show Library in Menu"


BUT, if I click it, it does not show library in Menu. Instead, it highlights the Library button on my toolbar. This is confusing.

(If I remove the library button from my toolbar using Customize Mode, *then* this onboarding-tour-button will highlight the library entry in the hamburger menu.  But under the default icon configuration, it highlights a button on the toolbar, not in the menu.)
Flags: needinfo?(rexboy)
Summary: In onboarding tour "Library" section, button is labeled "Show Library in Menu" -- but library is not in menu → In onboarding tour "Library" section, button is labeled "Show Library in Menu" -- but instead highlights a toolbar button
Whiteboard: [photon-onboarding][triage]
(using needinfo=rexboy to get this on his radar, since I've noticed him help out on other onboarding-tour bugs. Feel free to redirect as-appropriate, though. Thanks!)
FWIW, I'm using Nightly 57.0a1 (2017-08-22) (64-bit) on Ubuntu 17.04 Linux.
Hi Verdi,

the library's button string is incorrect now since we altered the library highlight support... Could you help figure out the right one?
Flags: needinfo?(rexboy) → needinfo?(mverdi)
Duplicate of this bug: 1393122
Flags: qe-verify+
Priority: -- → P2
QA Contact: jwilliams
Whiteboard: [photon-onboarding][triage] → [photon-onboarding]
(In reply to Fred Lin [:gasolin] from comment #4)
> Hi Verdi,
> 
> the library's button string is incorrect now since we altered the library
> highlight support... Could you help figure out the right one?

I talked to Michelle and we agreed that "Show Library Menu" is the correct string for the new behavior.
Flags: needinfo?(mverdi)
Attachment #8901029 - Flags: review?(rexboy)
Assignee: nobody → fliu
Status: NEW → ASSIGNED
Comment on attachment 8901029 [details]
Bug 1392822 - change the Library tour action button title to "Show Library Menu",

https://reviewboard.mozilla.org/r/172496/#review178346
Attachment #8901029 - Flags: review?(gasolin) → review+
Comment on attachment 8901029 [details]
Bug 1392822 - change the Library tour action button title to "Show Library Menu",

https://reviewboard.mozilla.org/r/172496/#review178348

::: commit-message-2306e:1
(Diff revision 3)
> +Bug 1392822 - In onboarding tour "Library" section, button is labeled "Show Library in Menu" -- but instead highlights a toolbar button, r?gasolin

please rename the bug commit to reflect the actual change, such as "Bug 1392822 - change button description to Show library menu"
Comment on attachment 8901029 [details]
Bug 1392822 - change the Library tour action button title to "Show Library Menu",

https://reviewboard.mozilla.org/r/172496/#review178348

> please rename the bug commit to reflect the actual change, such as "Bug 1392822 - change button description to Show library menu"

Updated, thanks
Keywords: checkin-needed
Pushed by flin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/26922f626539
change the Library tour action button title to "Show Library Menu", r=gasolin
Keywords: checkin-needed
Duplicate of this bug: 1394016
https://hg.mozilla.org/mozilla-central/rev/26922f626539
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
I have verified this fix on today's nightly.
Status: RESOLVED → VERIFIED
I can confirm the intended behavior is respected on beta. I verified using Fx 57.0b7 on Windows 10 x64, Ubuntu 14.04 LTS and macOS X 10.12.6.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.