[10.13] Firefox Dock icon defaults to System Icon

RESOLVED DUPLICATE of bug 493503

Status

()

P2
normal
RESOLVED DUPLICATE of bug 493503
a year ago
5 months ago

People

(Reporter: marcia, Unassigned)

Tracking

55 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox55 affected, firefox56 affected, firefox57 affected)

Details

Attachments

(1 attachment)

Created attachment 8900017 [details]
Screenshot of what should be the Firefox icon using 10.13

Might be 10.13 specific (running B7), using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:55.0) Gecko/20100101 Firefox/55.0, 20170814073321

STR:
1. Running 54.0.1, perform a manual update to 55
2. Update downloads, see attached screenshot

I rebooted my system and restarted the browser several times, but the icon remains.

A quick test using 10.12.6 and I did not see the same issue.
Adding Markus in case he has some ideas.
Flags: needinfo?(mstange)
status-firefox55: --- → affected
status-firefox56: --- → unaffected
status-firefox57: --- → unaffected
I don't have any ideas. We may need to reach out to Apple for this.
Flags: needinfo?(mstange)
Before I reach out to Apple, Andrei can you confirm you see the same thing using Beta 7 on your 10.13 test machine?
Flags: needinfo?(andrei.vaida)
Hello Marcia,
I tried reproducing this issue but I did not get the same result. I have a 2017 MacBook Pro with touchbar and macOS 10.13 Beta 7 installed. I installed 54.0.1 and then updated it from "about". The icon is not changed.
I have a screenshot here: http://imgur.com/a/A43NF
Flags: needinfo?(andrei.vaida) → needinfo?(mozillamarcia.knous)
Unfortunately, I am now seeing this with Beta as well, updating from Beta 5 to Beta 6.
Flags: needinfo?(mozillamarcia.knous)
status-firefox56: unaffected → affected
ni to spohl to see if he has any ideas. also moving to shell int.
Component: General → Shell Integration
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P2
Funky things have happened with macOS' icon cache before. Does this reproduce if Firefox is not kept in the Dock, close Firefox and reopen?

If you can still reproduce, it would be interesting to see what happens when the icon cache is cleared. There are some instructions on how to do this here:
https://apple.stackexchange.com/questions/225024/reset-icon-cache-on-macbook
Component: Shell Integration → Widget: Cocoa
Flags: needinfo?(spohl.mozilla.bugs) → needinfo?(mozillamarcia.knous)
Product: Firefox → Core
I have not seen this since the report. For now I will close as WFM, but I will keep on eye on things as we progress on this new OS.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mozillamarcia.knous)
Resolution: --- → WORKSFORME
This cropped up again in Beta 10, reopening for now.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Could you run through the suggestion in comment 7 and let me know what happens?
When I try to run that command in Terminal I get "Operation not permitted (it does ask for my password). I also tried rebooting my machine and the icon that shows for Beta is still the system icon.
(In reply to Marcia Knous [:marcia - use ni] from comment #11)
> When I try to run that command in Terminal I get "Operation not permitted
> (it does ask for my password). I also tried rebooting my machine and the
> icon that shows for Beta is still the system icon.

Looks as if https://gist.github.com/fabiofl/5873100 has some information on how to work around this error.
(In reply to Stephen A Pohl [:spohl] from comment #13)
> Did https://gist.github.com/fabiofl/5873100#gistcomment-2232236 fix the
> issue for you?

Haven't tried yet - will later tonight after my work day is done.
(In reply to Stephen A Pohl [:spohl] from comment #13)
> Did https://gist.github.com/fabiofl/5873100#gistcomment-2232236 fix the
> issue for you?

Yes, it did work. I rebooted and the beta icon is back.
But after doing a Mac system update to Version 4, as well as a Beta update, the issue is back. So even if resetting the icon cache worked once, it hasn't fully resolved the issue.
status-firefox57: unaffected → affected
[Tracking Requested - why for this release]: Not sure we can do much about this, but nominating in case we want to investigate this further. We also haven't had any other reports of this, so wondering what is unique about my setup that might be causing it if it is an aberration.
tracking-firefox57: --- → ?
This is known to affect people who test numerous different versions of Firefox in a disproportionate number. There is a lot of interaction between the icon cache, bundle identifiers, us changing icons for the same bundle identifiers etc that can cause this issue. Most users are not expected to ever run into it since they only run one channel of Firefox at any given time.
(In reply to Stephen A Pohl [:spohl] from comment #18)
> This is known to affect people who test numerous different versions of
> Firefox in a disproportionate number. There is a lot of interaction between
> the icon cache, bundle identifiers, us changing icons for the same bundle
> identifiers etc that can cause this issue. Most users are not expected to
> ever run into it since they only run one channel of Firefox at any given
> time.

Based on this, I will withdraw my tracking nom.
tracking-firefox57: ? → ---
See Also: → bug 1411837
(Reporter)

Updated

11 months ago
See Also: → bug 1432609
See Also: → bug 1433599
Hmm.... I don't think this is a matter of running a lot of versions of Firefox. I hacven't run !Nightly in quite some time (Weeks?) and it just happened on update.
ekr is in a state similar to me when I had this issue.  His app is "/Applications/FirefoxNightly.app", with no space.  Fresh installs go into a directory that does have a space.  Perhaps this is unrelated except for timing.

I've also NI'd Asa, since I know he's fielded questions from several users with this issue.
Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(asa)
This will be addressed by bug 493503. See bug 493503 comment 16.
Flags: needinfo?(spohl.mozilla.bugs)
Flags: needinfo?(asa)
Seeing this in 61.0a1 (2018-04-11) (64-bit) on 10.13.4 when I updated this morning. If bug 493503 is fixing this, can this be resolved as a dupe?
Flags: needinfo?(spohl.mozilla.bugs)
(In reply to Emma Humphries, Bugmaster ☕️ (she/her) [:emceeaich] (UTC-8) needinfo? me from comment #23)
> Seeing this in 61.0a1 (2018-04-11) (64-bit) on 10.13.4 when I updated this
> morning. If bug 493503 is fixing this, can this be resolved as a dupe?

Yes, let's do that.
Status: REOPENED → RESOLVED
Last Resolved: a year ago8 months ago
Flags: needinfo?(spohl.mozilla.bugs)
Resolution: --- → DUPLICATE
Duplicate of bug: 493503
You need to log in before you can comment on or make changes to this bug.