Mozilla mis-Loads & mis-Parses the Page

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: x86zman, Assigned: harishd)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Mozilla mis-matches HTML Comments with JS , and more Thereof :
I've done a "View Page Source" , and Saw that the Start of the Script was also
Missing - mozilla also mis-Loaded the Page !

I Think that these are Newly Introduced, 1.0rc1 issues only , as many Older
Versions of Mozilla Have Load&Parse this Page Flawlessly !

- I'm this Site Admin. so contact me with any whines ! ;->

P.S. : the Page also Load well with IE 5.5 sp2 (+ latest patches)

Comment 1

17 years ago
the problem is that you have a line that looks like this
"---------------------------------------------------------"
If you remove that line, everything should become OK.

You should not use "--" anywhere inside a comment started with '<!--'

If I remember SGML correctly, each '--' toggles comment mode.

Comment 2

17 years ago
this bug is invalid

Please reopen if you still have problems after reading my previous comment.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
F%%%ing SGML ...
I've "Fixed" that Comment , but anyway that's a BUG in Mozilla :
Mozilla have Trunacted the JS Because of that "Unterminated" Comment !!
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

17 years ago
Over to Parser.
Assignee: Matti → harishd
Component: Browser-General → Parser
QA Contact: imajes-qa → moied

Comment 5

17 years ago
Please explain how this is a bug in mozilla.
You never closed your comment causing the rest of the page never to be parsed.
(Assignee)

Comment 6

17 years ago
Your document is an XHTML document ( that's you've requested strict parsing )
which means that the document will not be shown any mercy. You've to have a good
markup to get the desired effect. If you're comments are not up to the spec. (
SGML ) then this is not a bug in mozilla. Marking the bug INVALID. Please reopen
if you can prove otherwise.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

17 years ago
Strict Parsing or Not , I Know that my Page is NOT 100% Complient with XHTML 
1.0 (yes, even with it's Transitional Edition) - but it's very Close to be .

and the Prove is that it Worked Very good with my IE , both with that naughty 
comment , and without !

and that Xactly why M$ IE has >10 Degree Users than Mozilla - say it Loud : 
Good Compatibility !

and Don't Even think that I'm Not Sorry for that Mozilla has Worse 
Compatibility to My Pretty-Well-Formed Page(s) than IE !!!
The browser's job is to parse markup, not to magically read the author's mind
and figure out what they intended to write.  Relying on browser DWIM*
capabilities will inevitably come back to bite you at some point.  Verified invalid.

*Do What I Mean
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.