Closed Bug 1392921 Opened 4 years ago Closed 4 years ago

Fix the wrong clipping problem on chrome ui in layers-free mode

Categories

(Core :: Graphics: WebRender, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla57
Tracking Status
firefox57 --- fixed

People

(Reporter: ethlin, Assigned: ethlin)

References

Details

Attachments

(1 file)

It looks like a regression of bug 1389138. I will try to have a patch for it.
I can reproduce the problem when loading a larger page, e.g.: "https://tw.yahoo.com". The refresh icon isn't clipped correctly.
Comment on attachment 8900141 [details]
Bug 1392921 - In TopmostScrollId(), return FrameMetrics::NULL_SCROLL_ID when the scroll id stack is empty.

https://reviewboard.mozilla.org/r/171534/#review176752

This is fine, although since the function now never returns Nothing() we can change the return type to just a plain FrameMetrics::ViewID instead of a Maybe<>. Feel free to make that change as well (the call sites will need to be tweaked accordingly). Or you can land this as-is, that's fine too.
Attachment #8900141 - Flags: review?(bugmail) → review+
Okay, I will change the return type.
Pushed by ethlin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d41aab9f4c34
In TopmostScrollId(), return FrameMetrics::NULL_SCROLL_ID when the scroll id stack is empty. r=kats
https://hg.mozilla.org/mozilla-central/rev/d41aab9f4c34
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
You need to log in before you can comment on or make changes to this bug.