boehm-enabled build crashes on startup

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
17 years ago
14 years ago

People

(Reporter: renelanz, Assigned: beard)

Tracking

({crash, stackwanted})

1.0 Branch
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020312
BuildID:    RC1 from CVS

The first time after building RC1 from CVS the startup suceeds. The following
startups crash...

Reproducible: Always
Steps to Reproduce:
1. build RC1
2. start ok, exit
3. start again, crash

my .mozconfig:

# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#

# Options for client.mk.
#mk_add_options MOZ_MAKE_FLAGS=-j4

# Options for 'configure' (same as command-line options).
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --enable-xpcom-lea
ac_add_options --disable-debug
#ac_add_options --enable-optimize="-O3 -fomit-frame-pointer -march=pentiumpro"
ac_add_options --enable-optimize="-O2 -march=pentiumpro"
ac_add_options --disable-dtd-debug

ac_add_options --enable-boehm
ac_add_options --enable-cpp-rtti

ac_add_options --disable-logging
#ac_add_options --enable-reorder
ac_add_options --enable-extensions
ac_add_options --disable-freetype2

# Build SVG
ac_add_options --enable-svg
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
MOZ_INTERNAL_LIBART_LGPL=1
(Reporter)

Comment 1

17 years ago
Created attachment 80459 [details]
strace output of crash

strace output of crash
(Reporter)

Comment 2

17 years ago
Created attachment 80461 [details]
stdout of crashing startup

stdout of crashing startup
(Reporter)

Comment 3

17 years ago
1) My setup:
o gcc --version:2.95.3
o uname -a: Linux java 2.4.4-4GB #1 Wed May 16 00:37:55 GMT 2001 i686 unknown
o Suse 7.2

2) I first tried to build with "-O3 -fomit-frame...", "-reordering-linker" and
the whole thing crashed even earlier. So I decided to be more conservative and
used the settings in .mozconfig.

3) By the way: If one chooses --enable-boehm, RTTI has to be selected as well,
otherwise the build will not suceed. ./configure doesn't complain, if one
doesn't select rtti but boehm. In my opinion this should be checked!

Updated

17 years ago
Keywords: crash
I know nothing about the boehm builds. Over to beard.
Assignee: seawood → beard
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: crash on startup → boehm-enabled build crashes on startup

Comment 5

14 years ago
Rene: Have you tried to build with gc ever since then? Does it still crash?
Product: Browser → Seamonkey

Comment 6

14 years ago
reporter: how about a stack trace in the future? straces are almost always useless

./mozilla -g -d gdb
run
where
Keywords: stackwanted

Comment 7

14 years ago
Old version, no further responses from reporter, no stack trace. Resolving as WFM.

Feel free to reopen the bug if you can reproduce the problem with current builds.
Severity: blocker → critical
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Version: Trunk → 1.0 Branch
You need to log in before you can comment on or make changes to this bug.