<object/> not the same as <object></object>

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
15 years ago

People

(Reporter: bugzilla.mozilla.org, Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.1 (X11; Linux i686; U;) Gecko/20020417
BuildID:    20020417

<object/> is not treated as closed, which results in the elements following it
not being rendered.

Using the DOM inspector, you can see that <p><object data="foo"/>bar</p> is
treated as if it was <p><object data="foo">bar</object></p>.  However,
<p><object data="foo"></object>bar</p> works as expected; the word bar is rendered.

Reproducible: Always
Steps to Reproduce:
1. See http://www.triv.org.uk/~mavit/test.html for an example.

Actual Results:  The word "wibble" was not rendered in the first paragraph.

Expected Results:  The word "wibble" should be rendered in both paragraphs.

This only seems to have happened since I upgraded from 0.9.9 to 1.0rc1.

I've only tried this with images as the object.
valid XHTML, so there is indeed a bug.
To parser.  We ignore the "/" thing in XHTML-as-HTML....  that seems like a bad
idea.
Assignee: attinasi → harishd
Status: UNCONFIRMED → NEW
Component: Layout → Parser
Ever confirmed: true
OS: Linux → All
QA Contact: petersen → moied
Hardware: PC → All
(Assignee)

Comment 3

17 years ago
Why is the document served as text/html instead of text/xml? Our html parser is
not there yet to support XHTML. So, please use the right mime type. 
Marking bug INVALID.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
We ignore the |/>| by design. We used to have support for that, but it caused
even more problems (people complaining why |<option/>foo| did not work, for
example). If you really want XHTML processing, use an XML mime type. That way
you will quickly see the well-formedness errors as well.

Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.