Crash when trying to share Firefox application

RESOLVED WORKSFORME

Status

()

Core
WebRTC: Audio/Video
P1
normal
Rank:
15
RESOLVED WORKSFORME
4 months ago
4 months ago

People

(Reporter: jkt, Unassigned)

Tracking

57 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox57 affected)

Details

(Reporter)

Description

4 months ago
I got the following crash:
https://crash-stats.mozilla.com/report/index/82d132fd-1053-4f48-82f7-6a1aa0170823


STR:

1. Go to https://mozilla.github.io/webrtc-landing/gum_test.html
2. Click application
3. In the door hanger pick firefox itself
Verified by Andreas, I am on OSX and I do not have Firefox in my list.
Rank: 15
Component: WebRTC → WebRTC: Audio/Video
Priority: -- → P1
Well, I didn't get a crash but rather a hang of both Firefox and Ubuntu chrome. Only the mouse cursor seemed to work. I had to kill Firefox through another terminal.

My doorhanger dropdown didn't have Firefox in it though, just my terminal. This is expected. The hang occurred when selecting the dropdown item.

jkt, can you repro that the door hanger displays Firefox as an option?
Flags: needinfo?(jkt)
(Reporter)

Comment 3

4 months ago
I see yellow squares when I selected one of my terminals (I had many open and I only saw one item for this) which looks like some form of graphics issue.
I also had another version of Firefox open I think, however I can see the browser toolbox from the same browser.
I can confirm mine crashes still when selecting the option.
Flags: needinfo?(jkt)

Comment 4

4 months ago
The yellow squares should only occur if the chosen window does not have focus. If you are running two instances of Firefox, then the other Firefox should show up in the list of Applications.

I tried reproducing this just now, with two Firefoxes, and did not get a crash using today's nightly on Ubuntu 17.04. :jkt, sorry to bug you again, but could you please try to repro one last time with Nightly and see if this is still occurring for you? Thanks!
Flags: needinfo?(jkt)
(Reporter)

Comment 5

4 months ago
I'm using Windows at the moment but I can't repro it.

I think I reproduced this on Ubuntu 16.04 however if you can't repro the crash it might be hardware specific/fixed so feel free to close.
Flags: needinfo?(jkt)
I couldn't reproduce per comment 2 anymore either. I'll close for now. Let us know if you run into issues again.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.