movemail requires write access to /var/spool/mail

RESOLVED WONTFIX

Status

MailNews Core
Movemail
--
minor
RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: Simon Waldman, Assigned: Adam D. Moss)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417
BuildID:    2002041711

Is there any reason that movemail should require write access to the
/var/spool/mail directory? It will not work if it only has write access for the
mailbox file itself, but seems to require the permission for the directory.
Making this directory world-writable seems like a bad idea if it's not necessary...

Reproducible: Always
Steps to Reproduce:
n/a
(Assignee)

Comment 1

16 years ago
It needs write access to be able to create the
lock-file.

Comment 2

16 years ago
/var/spool/mail should have 0177 permissions just like /tmp.
(Assignee)

Comment 3

16 years ago
-> WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 4

16 years ago
*** Bug 180781 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
This should be written on the movemail page.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.