rust can't find prthread.h and plhash.h when built with system NSPR/NSS

RESOLVED DUPLICATE of bug 1341234

Status

RESOLVED DUPLICATE of bug 1341234
a year ago
10 months ago

People

(Reporter: dan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8900231 [details]
complete build log

When trunk FF is built with system NSPR/NSS libs, then rust can't find prthread.h and plhash.h headers and the build fails.

(there are tons of messages)
...
   Compiling plane-split v0.6.0
   Compiling bindgen v0.29.0
   Compiling style v0.0.1 (file:///var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/servo/components/style)
error: failed to run custom build command for `style v0.0.1 (file:///var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/servo/components/style)`
process didn't exit successfully: `/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/toolkit/library/release/build/style-deda2e1a2673aa15/build-script-build` (exit code: 101)
--- stdout
cargo:rerun-if-changed=build.rs
cargo:out_dir=/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/toolkit/library/x86_64-unknown-linux-gnu/release/build/style-f444cb42f29340c7/out
cargo:rerun-if-changed=properties/Mako-0.9.1.zip
cargo:rerun-if-changed=properties/build.py
cargo:rerun-if-changed=properties/computed_value_flags.rs
cargo:rerun-if-changed=properties/data.py
cargo:rerun-if-changed=properties/declaration_block.rs
cargo:rerun-if-changed=properties/gecko.mako.rs
cargo:rerun-if-changed=properties/helpers.mako.rs
...
delete' cannot be declared 'inline' [-Winline-new-delete], err: false
/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:227:21: warning: replacement function 'operator delete' cannot be declared 'inline' [-Winline-new-delete], err: false
/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:233:21: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete], err: false
/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/dist/include/mozilla/mozalloc.h:239:21: warning: replacement function 'operator delete[]' cannot be declared 'inline' [-Winline-new-delete], err: false
/var/lib/jenkins/workspace/Firefox/label/x86_64/firefox-src/obj-x86_64-pc-linux-gnu/dist/include/nsString.h:162:10: fatal error: 'plhash.h' file not found, err: true
...

but the "fatal error" above looks as the culprit. The error doesn't show up when using the bundled NSPR/NSS.


PS: we have a private (for now) Jenkins instance doing builds for aarch64, ppc64, ppc64le, s390x and also for x86_64 as a reference build. The intention is to move the testing to public.
Component: Untriaged → NSPR
Product: Firefox → NSPR
Version: unspecified → other
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384659

Updated

11 months ago
Duplicate of bug: 1341234
You need to log in before you can comment on or make changes to this bug.