After restore from History menu, the closed windows does not have the same dimensions as before

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: roxana.leitan, Unassigned)

Tracking

(Blocks: 1 bug, {regression, regressionwindow-wanted})

57 Branch
regression, regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(firefox55 unaffected, firefox56 fix-optional, firefox57 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8900238 [details]
before restore.png

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
Build ID:20170822171841

[Affected versions]:
Nightly 57.0a1

[Affected platforms]:
Windows 10 x64, Ubuntu 16.04 X64

[Steps to reproduce]:
1.Launch Nightly 57.0a1 with a new profile
2.Open 3 windows (minimize/arrange them to the left/right desktop margins)
3.Close all windows
4.Reopen FF
5.Restore Previous Session from History menu

 
[Expected result]:
All windows should be restored and should have the same dimensions as before

[Actual result]:
All windows are restored but they don't have the same dimensions (please see attached screenshots)
(Reporter)

Comment 1

a year ago
Created attachment 8900239 [details]
after restore.png
(Reporter)

Updated

a year ago
QA Contact: adrian.florinescu
Whiteboard: [photon-performance][triage]
(Reporter)

Comment 2

a year ago
This issue is not reproducible on Mac OS X 10.12
Blocks: 1330633
Whiteboard: [photon-performance][triage]
Component: DOM: Core & HTML → Session Restore
Product: Core → Firefox
I mentioned this to AdrianSV over IRC - but if this is a regression introduced by bug 1358809, we should probably get this re-triaged by the Photon team.
(In reply to Mike Conley (:mconley) (:⚙️) from comment #3)
> I mentioned this to AdrianSV over IRC - but if this is a regression
> introduced by bug 1358809, we should probably get this re-triaged by the
> Photon team.

As this issue doesn't reproduce on Nightly 55/Release 55, this is not introduced as a regression from bug 1358809, therefore removing dependency to bug 1358809.
It seems that this bug is also affecting 56, but due to current priorities, we couldn't dive too deep into finding its regression range.
No longer blocks: 1358809
status-firefox55: --- → unaffected
status-firefox56: --- → affected
Keywords: regression, regressionwindow-wanted
Andrei, can you find someone else to look for the regression range? The regression engineering triage today discussed it and we feel this is a significant regression for many users.  To have a good chance at fixing it, we will still need a regression window. Thanks!
Flags: needinfo?(andrei.vaida)
Jean, can you make sure this regression is considered in terms of priority by the Photon team?
status-firefox56: affected → fix-optional
Flags: needinfo?(jgong)
Yes, it would be helpful to have a regression window. I think that's the next step for prioritizing this.

Mike, have you seen any similar reports?

If this is a bug that just results in small offsets or losing sizes when closing immediately after a resize (i.e. it would save the right size if you wait a bit before quitting, as would normally be the case in real usage), then it doesn't seem very high priority to me.
Flags: needinfo?(jgong) → needinfo?(mdeboer)
(Reporter)

Comment 8

a year ago
I do not see this issue reproducible anymore on 57.0a1 20170912220343 Win10x64(quantum ref. machine)and Ubuntu 16.04 x64.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(andrei.vaida)
Resolution: --- → WORKSFORME
OK, thanks Roxana. For posterity: I haven't seen similar issues pop up recently.
Flags: needinfo?(mdeboer)
You need to log in before you can comment on or make changes to this bug.