firefox-55.0.2/widget/gtk/gtk2drawing.c:3413: suspicious expression ?

RESOLVED INVALID

Status

()

RESOLVED INVALID
a year ago
25 days ago

People

(Reporter: dcb314, Unassigned)

Tracking

54 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170613080647

Steps to reproduce:

Compile source code with static analyser cppcheck.


Actual results:

firefox-55.0.2/widget/gtk/gtk2drawing.c:3413] -> [firefox-55.0.2/widget/gtk/gtk2drawing.c:3413]: (style) Same expression on both sides of '|'.

Source code is

    gtk_widget_style_get (gHorizScrollbarWidget,
                          "has-backward-stepper", &backward,
                          "has-forward-stepper", &forward,
                          "has-secondary-backward-stepper", &secondary_backward,
                          "has-secondary-forward-stepper", &secondary_forward,
                          NULL);
    return backward | forward | secondary_forward | secondary_forward;

Maybe better source code

    gtk_widget_style_get (gHorizScrollbarWidget,
                          "has-backward-stepper", &backward,
                          "has-forward-stepper", &forward,
                          "has-secondary-backward-stepper", &secondary_backward,
                          "has-secondary-forward-stepper", &secondary_forward,
                          NULL);
    return backward | forward | secondary_forward | secondary_backward;
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Closing GTK2 related bugs since we removed GTK2 support at the beginning of 2018 in bug 1278282. Probably best to open a new bug in the unlikely event that any of these are still relevant.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 25 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.