about:addons category titles get cut off in some locales

VERIFIED FIXED in Firefox 57

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: gustavo.silva, Assigned: mstriemer)

Tracking

({regression})

Trunk
mozilla57
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox55 unaffected, firefox56 unaffected, firefox57+ verified)

Details

Attachments

(7 attachments)

I'd say this was caused by bug 1380043 but I'm not sure, since supposedly it only changed the icons.

The content pane in about:addons seems to be slightly wider on the 2017-08-22 Nightly than it was on 2017-08-21, causing one of the category titles to be slightly cut off and a horizontal scroll bar appearing on the bottom of the window.

The attached example is taken from the European Portuguese (pt-PT) builds.
[Tracking Requested - why for this release]:
Has Regression Range: --- → yes
Keywords: regression
Assignee: nobody → mstriemer
Priority: -- → P3
Duplicate of this bug: 1393828
Duplicate of this bug: 1393680
I think this came from bug 1388997, this rule specifically:
http://searchfox.org/mozilla-central/rev/f2a1911ad310bf8651f342d719e4f4ca0a7b9bfb/toolkit/themes/shared/in-content/common.inc.css#649

Which makes me wonder if about:preferences has a similar issue?
Flags: needinfo?(jaws)
Flags: needinfo?(evan)
Duplicate of this bug: 1395388
(In reply to Andrew Swan [:aswan] from comment #5)
> I think this came from bug 1388997, this rule specifically:
> http://searchfox.org/mozilla-central/rev/
> f2a1911ad310bf8651f342d719e4f4ca0a7b9bfb/toolkit/themes/shared/in-content/
> common.inc.css#649
> 
> Which makes me wonder if about:preferences has a similar issue?

No, they wrap (from https://bugzilla.mozilla.org/show_bug.cgi?id=1393828#c1)

> For a possible reference: labels in the new prefs' sidebar wrap.
Redirecting my needinfo to Ricky as I'm too busy with animation work right now to investigate this.
Flags: needinfo?(jaws) → needinfo?(rchien)
Nice catch!

Per discussion with Helen(:HHuang) (Photon Preferences visual designer), the left side category of in-content page should wrap the text when it exceeds the width of category 240px.

The simplest way to fix that issue is to turn richlistitem's name attribute into label.textContent like Preferences [1].

[1] http://searchfox.org/mozilla-central/source/browser/components/preferences/in-content/preferences.xul#133-134
Flags: needinfo?(rchien)
Flags: needinfo?(evan)
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
[Tracking Requested - why for this release]: Visible UI regression which we should probably fix.
Duplicate of this bug: 1397973
Comment on attachment 8906854 [details]
Bug 1393099 - Wrap category titles in about:addons

https://reviewboard.mozilla.org/r/178576/#review184624
Attachment #8906854 - Flags: review?(rhelmer) → review+
Comment on attachment 8906854 [details]
Bug 1393099 - Wrap category titles in about:addons

https://reviewboard.mozilla.org/r/178576/#review184742

::: toolkit/mozapps/extensions/content/extensions.js:1890
(Diff revision 3)
>        gViewController.loadView(this.node.selectedItem.value);
>      });
>  
>      this.node.addEventListener("click", (aEvent) => {
>        var selectedItem = this.node.selectedItem;
> -      if (aEvent.target.localName == "richlistitem" &&
> +      if (aEvent.target.closest("richlistitem") == selectedItem) {

Made a minor change here to find the closest `richlistitem` rather than checking the clicked elements `localName` since it could be a label or image now. This was preventing clicking on the search entry taking you back to search.
I think the situation gets improved thanks to bug 1392532, so I the text is not cut off anymore, at least not for Czech.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/e0fe9ab6917b
Wrap category titles in about:addons r=rhelmer
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e0fe9ab6917b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Depends on: 1400379
In today's Nightly, where this fix landed, the "Recent Updates" string in pt-PT now spans two rows even though there still seems to be enough space to fit in a single line.

I'm needinfo'ing :mstriemer even though I'm not sure if I should do it—I'm not very experienced with Bugzilla—so I'm sorry if I shouldn't have, but otherwise I'm not sure if this bug would be noticed again now that it's marked as resolved.
Flags: needinfo?(mstriemer)
Depends on: 1400813
The regression should be fixed by bug 1400379. Long titles now get truncated with an ellipsis and the full string is shown in the tooltip on hover.
Flags: needinfo?(mstriemer)
This looks fixed in latest FF 57 for PT-pt (please see latest screenshot attached). Can we mark the issue as verified?
Flags: needinfo?(gustavo.silva)
Posted image Postfix screenshot
This caused some regressions which were fixed in bug 1400379, I'm not sure if we want this one to be marked as verified. That bug has already been fixed so it looks right, but this solution was to wrap the text and that no longer happens.
In any case, I do confirm the issue has been fixed in pt-PT.
Flags: needinfo?(gustavo.silva)
Since https://bugzilla.mozilla.org/show_bug.cgi?id=1400379 is marked as verified,I think that we can mark this as verified too and open separate issues if we will find another problems here.

Thanks
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.