Closed Bug 1393148 Opened 2 years ago Closed 2 years ago

Hide Topics component if no topics available in Activity Stream

Categories

(Firefox :: New Tab Page, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 57
Tracking Status
firefox56 --- fixed
firefox57 --- fixed

People

(Reporter: k88hudson, Assigned: k88hudson)

Details

Attachments

(1 file)

This fix hides the topics UI if no topics are available. This change is necessary  German users in 56 to not have a broken experience.
Summary: Hide Topics component if no topics available → Hide Topics component if no topics available in Activity Stream
Attachment #8900388 - Flags: review?(edilee)
Comment on attachment 8900388 [details]
Bug 1393148 - Hide Topics component if no topics available in Activity Stream

https://reviewboard.mozilla.org/r/171740/#review176982

Looks fine for nightly/mozilla-central. Won't apply cleanly to beta given the context difference: `    const maxCards = 3 * maxRows;` only exists on m-c. Also I guess this will look untested because we don't export content-src tests.
Attachment #8900388 - Flags: review?(edilee) → review+
Pushed by khudson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/360a9abdd9ea
Hide Topics component if no topics available in Activity Stream r=Mardak
https://hg.mozilla.org/mozilla-central/rev/360a9abdd9ea
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Comment on attachment 8900388 [details]
Bug 1393148 - Hide Topics component if no topics available in Activity Stream

Approval Request Comment
[Feature/Bug causing the regression]: Topics are broken for users in Germany
[User impact if declined]: The pocket experience will appear buggy/broken for German users for the Activity Stream shield study
[Is this code covered by automated tests?]: Yes, in https://github.com/mozilla/activity-stream
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: No
[Is the change risky?]: No
[Why is the change risky/not risky?]: One line change, affects shield study only (Activity Stream is pref'd off by default)
[String changes made/needed]: None
Attachment #8900388 - Flags: approval-mozilla-beta?
Comment on attachment 8900388 [details]
Bug 1393148 - Hide Topics component if no topics available in Activity Stream

UI polishment for Activity Stream. Beta56+.
Attachment #8900388 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Assignee: nobody → khudson
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.