Don't open unrequested javascript windows not working

VERIFIED DUPLICATE of bug 126224

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 126224
16 years ago
14 years ago

People

(Reporter: Rick Jackson, Assigned: Samir Gehani)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020422
BuildID:    2002042209

  I have in Edit->Preferences->Advanced->Scripts & Windows the checkbox for
allow webpages to: open unrequested windows currently UNCHECKED.  However, I am
seeing a window pop-up when I go to a particular link on weather.com.  This
wasn't happening before.  I was able to prevent these annoying windows with your
feature to not allow web pages to open unrequested windows.  I have included the
steps to reproduce below.

Reproducible: Always
Steps to Reproduce:
1.  Go to www.weather.com
2.  At the upper right there is a link to "My Weather"
3.  Click on that link


Actual Results:  The page loads, and then a pop-up to Trip.com shows up as well

Expected Results:    Mozilla should prevent this window from popping up when I
don't have the "Allow webpages to open unrequested windows" option unchecked.

Comment 1

16 years ago
The site uses a different method to open the popup.
Bug 126224 has already been fixed allowing you to block this method, however
there's no Interface for it. see bug 132031 for that.
For now, you can add
user_pref("dom.disable_open_click_delay", 1000);
To your prefs.js file in your profile to enable this manually.

*** This bug has been marked as a duplicate of 126224 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
WFM, same build on Windows 98.

Updated

16 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 3

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.