l10n isn't testable on try, can't get en-US revision

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
3 months ago
a month ago

People

(Reporter: Pike, Assigned: Callek)

Tracking

other

Firefox Tracking Flags

(firefox58 fixed)

Details

MozReview Requests

Submitter Diff Changes Open Issues Last Updated
Loading...
Error loading review requests:

Attachments

(1 attachment)

(Reporter)

Description

3 months ago
I've tried to get l10n to work on try, and it's been useless.

All variants die, for various reasons, but for sure because they can't get the en-US revision.

https://treeherder.mozilla.org/#/jobs?repo=try&author=axel@mozilla.com is full of fail, and I'm flipping tables at this point. Frustrating day.
I'm going to guess that bug 1391643 isn't complete. The first few tasks seem to be failing because there's an action task that CoT can't verify; not sure if you tried to backfill tasks or if this is a side effect of `mach try fuzzy`?
For https://treeherder.mozilla.org/#/jobs?repo=try&author=axel@mozilla.com&selectedJob=125163786 and https://treeherder.mozilla.org/#/jobs?repo=try&author=axel@mozilla.com&selectedJob=125218113 , we expect to get 'revision' from the buildbot properties. I'm not sure why we need revision at this point, since we've already cloned try; we might be able to hack https://hg.mozilla.org/mozilla-central/file/d1c70c20e7b5/testing/mozharness/scripts/desktop_l10n.py#l469 to run an `hg ident` or something?
(Reporter)

Comment 3

3 months ago
What I've tried with https://hg.mozilla.org/try/rev/015a29439771ce84032ac5375e57c2b405d1524e and https://hg.mozilla.org/try/rev/5f704edcabe8d971ea41680abd1b0b0b1a13cc4a was to get into the code path in https://hg.mozilla.org/mozilla-central/file/d1c70c20e7b5/testing/mozharness/scripts/desktop_l10n.py#l494 that does 

  revision = self._query_enUS_revision()

Apparently I had no luck in doing so.

The Nr fails came out of backfills and also retriggered failed N builds.
Maybe try nuking upload_env from testing/mozharness/configs/single_locale/try.py ? That's the main thing different that I'm seeing atm.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=ba2e707bc564ddce2cd992e00ae1581e567834b0 , based off your latest try push, so the try_task_config.json exists.
(Reporter)

Comment 6

3 months ago
That try push failed with the same revision error message.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=6dc64dc2900283b8125462fc6b84d48106afc51d
\o/ https://treeherder.mozilla.org/#/jobs?repo=try&revision=6dc64dc2900283b8125462fc6b84d48106afc51d

Most likely, we need something to detect try at https://hg.mozilla.org/mozilla-central/file/tip/testing/mozharness/scripts/desktop_l10n.py#l496 , and pull the revision from elsewhere (`make ident` like https://hg.mozilla.org/mozilla-central/file/tip/testing/mozharness/scripts/mobile_l10n.py#l220 ? `hg ident` ?) but modifying the tc_win64.py is the current workaround.
(Assignee)

Updated

2 months ago
Assignee: nobody → bugspam.Callek
(Reporter)

Comment 9

a month ago
I've just hit this again on https://treeherder.mozilla.org/#/jobs?repo=try&revision=3e111f30d71d044f85de57b893e6d96a1bcbf97e&selectedJob=136850854, where I forgot to work around this bug with a local patch.

It'd be great if we could get this fixed.
(Assignee)

Comment 10

a month ago
I did a try push that I think fixes this properly... https://treeherder.mozilla.org/#/jobs?repo=try&revision=720c9e47543bf0e400f0c8fb0034f961451dbeac
Comment hidden (mozreview-request)

Comment 12

a month ago
mozreview-review
Comment on attachment 8918595 [details]
Bug 1393190 - Pass revision in to mozharness, so we can run correctly on windows try without needing to play with hg commands, since it's not passed via a shell script.

https://reviewboard.mozilla.org/r/189428/#review194686
Attachment #8918595 - Flags: review?(aki) → review+

Comment 13

a month ago
Pushed by Callek@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/788c12045097
Pass revision in to mozharness, so we can run correctly on windows try without needing to play with hg commands, since it's not passed via a shell script. r=aki
https://hg.mozilla.org/mozilla-central/rev/788c12045097
Status: NEW → RESOLVED
Last Resolved: a month ago
status-firefox58: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.