Closed Bug 1393207 Opened 2 years ago Closed 2 years ago

Mobile Firefox push to Play Store always re-sets the update rate to 10%

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox56 fixed, firefox57 affected)

RESOLVED FIXED
Tracking Status
firefox56 --- fixed
firefox57 --- affected

People

(Reporter: lizzard, Assigned: kmoir)

References

Details

Attachments

(1 file, 1 obsolete file)

When we push the APKs to the Play Store for beta releases, the update rate is always reset to 10%. We have to adjust it by hand for every beta release. Intentional, or something we can fix for the future?
My understanding from mtabara that it is intentional to allow relman to adjust the rate as releng doesn't have access to the store. Also, the default is at a low rate to allow a staged rollout as needed.  Is there a better default rate that you would like us to set it to in automation?
Flags: needinfo?(lhenry)
Let's check with Sylvestre here for what he intends. (No rush, i think he is on PTO) Is there a way to leave it at whatever the previous push was rather than re-setting it with each beta?
Flags: needinfo?(lhenry) → needinfo?(sledru)
My intent in bug 1358420 is for the first beta to use 10%, and then later on to either adjust the percentage or just backout that change on m-b when we were ready to go 100%, so subsequent betas wouldn't need manual adjustment.  I'm afraid I didn't actually communicate or document that though, my bad...
Attached patch bug1393207.patch (obsolete) — Splinter Review
I'll also open a bug to reset the rate to 10% before the next b1.
Assignee: nobody → kmoir
Attachment #8900727 - Flags: review?(jcristau)
(In reply to Kim Moir [:kmoir] ET from comment #5)
> I'll also open a bug to reset the rate to 10% before the next b1.

That shouldn't be necessary, m-c already has the 10% rate, and any change we make for 56 should only land on m-b.
Comment on attachment 8900727 [details] [diff] [review]
bug1393207.patch

Review of attachment 8900727 [details] [diff] [review]:
-----------------------------------------------------------------

better backout bug 1358420 on m-b entirely imo if we're going 100%
Attachment #8900727 - Flags: review?(jcristau) → review-
Duplicate of this bug: 1393456
Attachment #8900727 - Attachment is obsolete: true
Attachment #8900739 - Flags: review?(jcristau)
Comment on attachment 8900739 [details] [diff] [review]
bug1393207-2.patch

Review of attachment 8900739 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm
Attachment #8900739 - Flags: review?(jcristau)
Attachment #8900739 - Flags: review+
Attachment #8900739 - Flags: approval-mozilla-beta+
Kim pushed this to Beta. I assume it'll be landing on inbound still.
https://hg.mozilla.org/releases/mozilla-beta/rev/aa85d946916f
No, I didn't land it on inbound because we want it to be reverted for the next b1.  See comment 6
Just like Julien said in comment #3.
Flags: needinfo?(sledru)
Was the google play rate set to 100% with Fennec b7?  Please verify so I can close this bug?

Also, a fyi when we do the merge and the first 57.0b1 runs, the build will run the rollout plan again at 10% since we just landed this change on beta, not on trunk.  So the google play store config for beta will have be changed again for the rollout plan instead of the full release
Flags: needinfo?(lhenry)
from #releaseduty

jcristau> Julien Cristau kmoir: Rollout 100% for fennec beta 56.0
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
OK. Thanks Kim. We will keep it in mind to check on the update rate and adjust it after beta 1 rollout.
Flags: needinfo?(lhenry)
You need to log in before you can comment on or make changes to this bug.