forward button not working with pdf

VERIFIED FIXED

Status

SeaMonkey
General
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: Sebastian Sandberg, Assigned: jag (Peter Annema))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2 RTM] custrtm-)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0rc1)
Gecko/20020417
BuildID:    2002041711

The forward button is not working after viewing a pdf file.

Reproducible: Always
Steps to Reproduce:
1.Open any pdf file
2.Press back
3.

Actual Results:  forward button greyed out

Expected Results:  not greyed out
confirmed on Linux, 1.0RC1
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
The page is getting added to session history, (You can use the go menu to reach
the page) but it looks like we are not updating the  back/forward buttons.
Blaker,Jag,av any ideas on where notifications go when plugins are loaded.
(Assignee)

Comment 3

16 years ago
onLocationChange is where we update the buttons from. Could you add some dumps
there to see if that gets executed?
jag: I see this error on the stdout when I load a PDF page. Obviously the Back
forward buttons are not updated because of this.

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "content.document has no properties" {file: "
chrome://navigator/content/nsBrowserStatusHandler.js" line: 316}]' when calling
method: [nsIWebProgressListener::onLocationChange]"  nsresult: "0x80570021 (NS_E
RROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "<unknown>"  data: yes]
************************************************************
Assignee: radha → jaggernaut
Component: History: Session → Browser-General
(Assignee)

Comment 5

16 years ago
Created attachment 81872 [details] [diff] [review]
Make sure there is a content.document
(Assignee)

Comment 6

16 years ago
Christian, could you r= this patch?
(Assignee)

Updated

16 years ago
Keywords: mozilla1.0, nsbeta1
Comment on attachment 81872 [details] [diff] [review]
Make sure there is a content.document

r=biesi
Attachment #81872 - Flags: review+

Comment 8

16 years ago
Comment on attachment 81872 [details] [diff] [review]
Make sure there is a content.document

sr=alecf

though technically this should be 
if ("document" in content &&...
Attachment #81872 - Flags: superreview+
(Assignee)

Comment 9

16 years ago
No it shouldn't be. |window| will always have a |document| property (see
nsIDOMWindow.idl), it can just be null at times.
(Assignee)

Updated

16 years ago
Keywords: adt1.0.0
(Assignee)

Comment 10

16 years ago
Checked in to trunk
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
Keywords: nsbeta1 → approval, nsbeta1+
Whiteboard: [adt1] [Needs a= & adt1.0.0+]

Comment 11

16 years ago
Let's get this one in after RC2. adt1.0.0- [adt2 RTM]. Pls land this on the trunk.
Keywords: adt1.0.0 → adt1.0.0-
Whiteboard: [adt1] [Needs a= & adt1.0.0+] → [adt2 RTM]

Comment 12

16 years ago
adding adt1.0.0+.  Please get drivers approval and then checkin to the 1.0 branch.
Keywords: adt1.0.0- → adt1.0.0+
(Assignee)

Comment 13

16 years ago
*** Bug 145742 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Whiteboard: [adt2 RTM] → [adt2 RTM] custrtm-

Comment 14

16 years ago
changing to adt1.0.1+ for checkin to the 1.0 branch for the Mozilla1.0.1
milestone.  Please get drivers approval before checking in.
Keywords: adt1.0.0+ → adt1.0.1+

Updated

16 years ago
Keywords: mozilla1.0 → mozilla1.0.1
Comment on attachment 81872 [details] [diff] [review]
Make sure there is a content.document

Approved for 1.0 branch.  Please remove mozilla1.0.1+ when it's fixed and add
fixed1.0.1
Attachment #81872 - Flags: approval+

Updated

16 years ago
Keywords: approval, mozilla1.0.1 → mozilla1.0.1+
(Assignee)

Updated

16 years ago
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 16

16 years ago
VERIFIED Fixed with 20020627 branch and trunk builds
Status: RESOLVED → VERIFIED
Keywords: fixed1.0.1 → verified1.0.1
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.