Closed Bug 1393223 Opened 5 years ago Closed 5 years ago

Standard/default add-ons icons are missing on add-ons using them in Add-ons Manager/about:addons

Categories

(Toolkit :: Add-ons Manager, defect, P1)

57 Branch
x86_64
Windows 7
defect

Tracking

()

VERIFIED FIXED
mozilla57
Iteration:
57.2 - Aug 29
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- unaffected
firefox57 --- verified

People

(Reporter: Virtual, Assigned: daleharvey)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [reserve-photon-visual])

Attachments

(2 files)

Attached image screenshot.png
Standard/default add-ons icons are missing on add-ons using them in Add-ons Manager/about:addons

STR:
1. Install some extension with standard add-on icon, like e.g. "Firefox Pioneer" extension ( https://addons.mozilla.org/en-US/firefox/addon/polish-spellchecker-dictionary/ )
2. Install some dictionary with standard add-on icon, like e.g. "Polish Spellchecker Dictionary" - ( https://addons.mozilla.org/en-US/firefox/addon/polish-spellchecker-dictionary/ )
3. Go to about:addons
and see that these extensions with standard add-on icon are missing these icons, there is just blank place
Language packs are probably also affected.


Regression range (mozilla-central):
Good:
https://ftp.mozilla.org/pub/firefox/nightly/2017/08/2017-08-21-10-03-50-mozilla-central/

Bad:
https://ftp.mozilla.org/pub/firefox/nightly/2017/08/2017-08-22-10-05-29-mozilla-central/

Regression range pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7dddbd85047c6dc73ddbe1e423cd643a217845b3&tochange=eb72c8c077518c3fdc0dca5c0a14070bd25fe3cb

Probably caused by:
Bug #1380043
Flags: needinfo?(dharvey)
Has Regression Range: --- → yes
Has STR: --- → yes
The xul:image's here do not have a size specified, it seems like for png's they would show their natural size but for svgs they are sticking with 0x0
Assignee: nobody → dharvey
Flags: needinfo?(dharvey)
Status: NEW → ASSIGNED
Iteration: --- → 57.2 - Aug 29
Flags: qe-verify+
Priority: -- → P1
Whiteboard: [photon-visual] [triage] → [reserve-photon-visual]
(In reply to Dale Harvey (:daleharvey) from comment #1)
> The xul:image's here do not have a size specified, it seems like for png's
> they would show their natural size but for svgs they are sticking with 0x0

This is because the svg doesn't have height and width attributes set. Can we fix that?
Flags: needinfo?(dharvey)
Sure can do
Flags: needinfo?(dharvey)
See Also: 1393361
Duplicate of this bug: 1393361
Comment on attachment 8900688 [details]
Bug 1393223 - Add default width to about:addons icons.

https://reviewboard.mozilla.org/r/172128/#review178142
Attachment #8900688 - Flags: review?(dao+bmo) → review+
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a849c30cf46a
Add default width to about:addons icons. r=dao
https://hg.mozilla.org/mozilla-central/rev/a849c30cf46a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla57
I'm confirming that bug is fixed, starting in Mozilla Firefox Nightly 57.0a1 (2017-08-27), so I'm marking this bug as VERIFIED. Thanks.
Status: RESOLVED → VERIFIED
Flags: qe-verify+

In Troubleshooting Information I see 5 Add-ons, Type Extension.
In Add-ons & Themes, none.

Release 91.3.1

In Troubleshooting mode too.

You need to log in before you can comment on or make changes to this bug.