Show Recent Downloads Menu Item when a user drags any downloadable content on a page.

RESOLVED DUPLICATE of bug 1393103

Status

()

Firefox
Menus
RESOLVED DUPLICATE of bug 1393103
4 months ago
4 months ago

People

(Reporter: bbell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
(In reply to Tooru and Kestrel  from comment #57-#61) on (Bug 1371765))

Users get utility from having the ability to drag any downloadable item from a page to the Recent Downloads Menu. 

This ability, while obscure, is a powerful feature that should continue to be available, and later improved on.
(Reporter)

Comment 1

4 months ago
Can you add you thoughts to this bug?
Flags: needinfo?(kestrel)
Flags: needinfo?(arai.unmht)
just posted a comment about visibility, to bug 1371765 before noticing this bug.
copying from there (although you've already answered there)

(In reply to Tooru Fujisawa [:arai] from comment #63)
> having the drop target before starting drag-and-drop action is important.
> 
> if the download button is hidden by default and gets visible only while
> dragging,
> user cannot certainly start the action "drag-and-drop this item to the
> download button there",
> since the target is missing, and cannot be sure the action can be performed.

so, instead of showing it only when dragging items,
showing it always and highlight it while dragging seems to be better, if we want to "highlight" the button's ability.
Flags: needinfo?(arai.unmht)
Blocks: 1371765
duping to bug #1393103, as this bug is about same thing
No longer blocks: 1371765
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1393103
(Reporter)

Updated

4 months ago
Flags: needinfo?(kestrel)
You need to log in before you can comment on or make changes to this bug.